1

Every time I go into the mouse settings form, to move the sensitivity sliders, I accept the settings and it makes no difference.

When I open the settings again, the sliders are all the way to the left, and not where I left them. Why are my settings not saved?

There a few other people asking the same question but all the answers require that I have to run terminal commands or edit files. Is this version of Ubuntu just wrong for me, can someone advise - because it's really frustrating when simple things fail silently in an operating system.

It a USB Mouse. I'm struggling with a few other things too, but this mouse sensitivity is the biggest blocker right now.

Sorry if this is a duplicate question, but I would like a answer that does not involve running a text editor (because that's something else that also "falls-over" for me.) I just want the mouse settings form to work.

0

I am sorry, but I did not see a chance to alter anything in a system that is not provided via the system GUIs without editing text files and/or executing commands.

My recommendation is this answer https://askubuntu.com/a/205914/40569 as it helped me to reduce my mouse speed.

If you have problems with implementing those changes to your system, just ask and we will try to help you.

There are a few remarks/improvements to the answer I linked above:

  • This has to be done after every login, but one can use a startup script for that
  • It is possible to use the device name instead it's ID

Step for step description (this will take you about 10 minutes):

  1. Open terminal: press Alt+F2, enter gnome-terminal and press the execute button

  2. List your input devices to identify the exact name of your mouse. Enter xinput list and press ENTER to see an output similar to the following:

    nsk@mycomputer:~$ xinput list
    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ USB keyboard                              id=9    [slave  pointer  (2)]
    ⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=10   [slave  pointer  (2)]
    ⎜   ↳ Logitech USB Receiver                     id=11   [slave  pointer  (2)]
    ⎜   ↳ Logitech USB Receiver                     id=12   [slave  pointer  (2)]
    ⎜   ↳ Microsoft Natural® Ergonomic Keyboard 4000    id=16   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Power Button                              id=7    [slave  keyboard (3)]
        ↳ USB keyboard                              id=8    [slave  keyboard (3)]
        ↳   USB Keyboard                            id=13   [slave  keyboard (3)]
        ↳   USB Keyboard                            id=14   [slave  keyboard (3)]
        ↳ Microsoft Natural® Ergonomic Keyboard 4000    id=15   [slave  keyboard (3)]
    
  3. You can see that my mouse is named Logitech USB-PS/2 Optical Mouse. Remember the name of your mouse from here. Additionally remember your logon name, that is printed at the very beginning until the @ sign - it is nsk for me.

  4. Now open a text editor (just try it, this is of no evil!)

  5. Enter the following lines with replacing the name of my mouse with the name of your mouse you identified in step 2:

    xinput set-prop "Logitech USB-PS/2 Optical Mouse" "Device Accel Profile" -1
    xinput set-prop "Logitech USB-PS/2 Optical Mouse" "Device Accel Constant Deceleration" 1
    
  6. Save the file as "mouseproperties" in your personal directory in subdirectory "bin" (if it does not exist, create it)

  7. Add a call of those xinput command lines in your startup programs: press Alt+F2 again, enter gnome-session-properties and press the execute button

    enter image description here

  8. Press the button for adding a new program call

  9. In the following dialog choose a name and comment and enter the following in the command line:

    sh /home/<YOUR-LOGON-NAME>/bin/mouseproperties
    

    enter image description here

  10. Press the add button

  11. You will see this "program" now listed with your name. This will be executed now at every login. Tune the value of "1" for "Device Accel Constant Deceleration" to fit your needs.

  • This should not have to be so difficult at all. Your description does not clarify what the numerical parameters values permissable are and how to find the other settings as well. I am guessing that the 10 in – Conrad B Jan 4 '14 at 20:05
  • value 1 for "Device Accel Constant Deceleration" works OK for me, but 2 is too fast, and there is nothing in between because it only accepts integers. I managed to follow your steps so you get a definit vote - but it still feels broken. – Conrad B Jan 4 '14 at 20:23
  • Sorry I cannot mark @peter answer as correct because I need 15 reputation first. Hope someone else can accept this improved answer. – Conrad B Jan 4 '14 at 20:24
  • Yes I agree that this should not be so difficult and that there is something broken. I don't understand why this does not get fixed. But nevertheless I appreciate this working workaround.Sadly I don't know further mechanics of those numbers as I learned them from the linked post as well. – Nicolas Jan 5 '14 at 23:44
  • 1
    Moved to a linux Mint16 (cinnamon) instead since not only did the mouse work, (i get the same setting screen, but the settings actually do work) but the graphics card also worked right away. Mint is based on Debian or Ubuntu I think (should I even know that?) Anyway one thing I did learn is to try the Gui first, and then try the shell solutions second :) – Conrad B Jan 31 '14 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.