2

I am new to ubuntu and I just installed it. when I tried to install git using "apt-get install git" I received error with "unable to connect". Then I found this question and did as what the question said. I installed git without any problem(I also installed vim and postgresql, no problem). But I received the following the error when I do "apt-get update".

W: GPG error: http://extras.ubuntu.com precise Release: The following signatures were invalid: BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com>

Then I replaced the sources.list with the original one--the previous one when I had problem using apt-get install. and the strange thing is that I can use apt-get install(all i did was just stop using the list file and used another one and then revert to the original one and the original one suddenly works for install) I still have the same error with update.

so what was wrong previously? why did I receive error now?

2

open a terminal and type:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 16126D3A3E5C1192

i.e. paste using SHIFT + INS the number you have copied - 16126D3A3E5C1192

You'll have to enter your password, the key will be downloaded and integrated.

  • can you explain this a little bit more? – Junchao Gu Jan 17 '14 at 7:47
  • 2
    I have been using Ubuntu for years, and I have never had to manually install signing keys in order to run apt-get update. Also the error message is not indicating that the public key is missing but rather that the signature is bad. – kasperd Oct 4 '14 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.