18

Can I somehow put Viber notification icon on top of the Unity panel (near Dropbox and others)?! It's pretty ugly to stay in top left corner...

2
  • Hi @Marko. I also have the same problem, and it is quite annoying. Did you find anything that solves the problem?
    – Jim Blum
    Jun 11, 2014 at 0:53
  • Hi @JimBlum! Unfortunately no, I gave up on this. Jun 13, 2014 at 17:44

6 Answers 6

19

Solution - use Viber wrapper to launch the program

To fix this, you need to install Viber Indicator package, which is a wrapper for Viber.

Once it's installed, use viberwrapper-indicator (showing gray icon in the notification area) instead of viber (which shows the purple icon).

You may also later add viberwrapper-indicator to startup programms.

Installation

Here's how to install the indicator wrapper via PPA:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install viberwrapper-indicator

Alternatively download the .deb file, and install it manually:

After the download of the .deb file: sudo dpkg -i viberwrapper-indicator_0.1.1-git20150611-webupd8-0_amd64.deb

After installation it will look like you - and others would - want it:

enter image description here

Note the new icon in the notification area.

Sources

Related Pages:

5
  • 1
    I think I used this once and worked but not any more. Any idea for another solution to remove the floating icon from the top left of the screen?
    – Tosho
    Feb 21, 2015 at 20:35
  • 3
    Didn't work for me on Ubuntu 14.04.
    – umpirsky
    Feb 24, 2015 at 7:50
  • 1
    Didn't work form me on Ubuntu 14.10 too.
    – sparkmood
    Feb 24, 2015 at 8:23
  • 2
    The answer here does not point out that you should launch viber indicator not viber itself. From article: launch Viber Indicator from the Dash / menu, instead of launching Viber itself. I'm on Ubuntu 14.04 and it works as it should. Apr 13, 2015 at 17:04
  • @IvanIvanić I launch Viberwrapper instead of viber. However, both viber's AND viberwrapper's icons show, with the one being at the left top corner. So, yes, this does not work for me at ubuntu 14.04.
    – Jim Blum
    May 31, 2015 at 8:41
8

you can do it by :

sudo apt-add-repository ppa:gurqn/systray-$(lsb_release -sc)
sudo apt-get update
sudo apt-get upgrade

Log out and Log in.

2
0

This github project https://github.com/karas84/viberwrapper-indicator worked for me.

0

Aside from this Viber Wrapper, I think is possible with dconf-tools to change whitelist applications to ['all'].

0

Run Viber with StartMinimized parameter.

/opt/viber/Viber StartMinimized
0

I've just upgraded Viber on my Ubuntu 14.04 LTS to the latest version:

dpkg -s viber
Package: viber
Status: install ok installed
Priority: extra
Section: non-free/net
Installed-Size: 350908
Maintainer: Viber Media Inc <support@viber.com>
Architecture: amd64
Version: 6.0.1.5

And the icon appears in the right place:

enter image description here

Congrats!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.