This is the most unusually problem that I have. I have an AMD Turion TL-56 processor. It's dual core and the default frequency is 1.8 ghz. For the past few months, the clock speed has been droppign to 800mhz. I installed a program that allows me to control the clock speed for the K8 processor family called cpupowerd so I am able to adjust the speed back to what It's suppose to be easily. I installed the program about 2 months before this problem started happening.

It typically occurs when I'm running an application, or applications that require a rather large amount of system resources. If I run videos on youtube via firefox, occasionally the clock speed will drop, not necessarily though. I will be obvious as the machine starts to become somewhat unresponsive, and with video streaming, the frame rate will drop dramatically. I know the clock speed of the processor is dropping because of the outputs from:

$ cat /proc/cpuinfo | grep "MHz"
cpu MHz     : 800.000
cpu MHz     : 800.000


$ sudo cpupowerd -s
cpupowerd 0.2.1 written by Markus Strobl.
WARNING: This program could cause damage to your Hardware!
Vendor                      : AMD
Family                      : K8
Model                       : 4
  Mastercpuid               : 0
    Affected cpuids         : 0 1
    Current voltage (VID)   : 0.8000 V (30)
    Current frequency (FID) : 800 MHz (0)
    Supported frequencies   : 800 1600 1800 MHz

I am able to reset it with

$ sudo cpupowerd --freq "0|1800"
cpupowerd 0.2.1 written by Markus Strobl.
WARNING: This program could cause damage to your Hardware!

For a while I thought something from Chrome was causing the problem (as there were several Chrome processes running even when I wasn't using the browser). However, I uninstalled Chrome and the problem still persists whenever I need to do something that requires more resources. This is particularly a problem when I run virtualbox which will cause the system to lock up completely (800mhz on a dual core processor just can't handle the sudden load).

When booting, accessing the system bios doesn't let me adjust the clockspeed which is set to 1800mhz (as I want it).

What is causing this shift in processing speed? Are there any logs that I can access that might shed light?

Edit: Regardless of what speed the processor is actually running out, dmidecode reports 1800MHz

$ sudo dmidecode -t processor | grep "Speed" 
    Max Speed: 1800 MHz
    Current Speed: 1800 MHz
  • @K7AAY It never occurred to me that it could be a hardware problem. Is there any way for me to verify that this is the cause? – Nil Jan 4 '14 at 0:57
  • This could be related to a problem with your system's power management as well. – Dillmo Jan 4 '14 at 0:58
  • @Dillmo this is an old notebook with lots of problems, I keep it plugged in 24/7 since the battery has less than a planck second of battery life. However, it's been running at optimal processing speed nearly a year under ubuntu before the clock speed started to drop, I think it may have something to do with it over heating, as I tweaked the videocards speed using rovclock (it should be producing more heat). – Nil Jan 4 '14 at 1:03

OK, suggest you time how long it takes to start dropping in speed.

Then, if you're somewhere frosty, take it outside. Does the speed pick back up again after a bit? If you are not somewhere frosty (Scofield Barracks, say, or Oz), borrow a hair drier and put it on no heat/fan only, then point it at your lappie's intake vent. This could show an old, tired fan, or (more likely in 30 yrs of experience with these infernal devices) there's foreign objects within obstructing airflow. (Got cats?)

Or, install a temperature sensor: Is there a hardware temperature sensor indicator? has the details.

  • I place a fan outside vent to blow large amounts of air toward the processor. I've been watching videos, running multiple applications at once, running virtual box at the same time. My processor speed doesn't drop. I think you were correct. – Nil Jan 4 '14 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.