1

This question already has an answer here:

I have been trying for a few hours to get Virtual Box running in Ubuntu 13.10 Every time I try to run a virtual machine running 64 bit Arch Linux I get an error message that says:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary

When I do what the error prompt tells me, I get another error saying that the directory doesn't exist. I have done research on the forums, and I have found nothing that works. It may be use full to know that I have Virtual Box installed from the Ubuntu Software Center, and not from virtualbox.org because whenever I try to run the .deb file downloaded from there, Ubuntu Software Center doesn't let me use it for some reason.

Any help would be greatly appreciated! Thanks, J

marked as duplicate by user117103, Eric Carvalho, karel, Avinash Raj, mikewhatever Jan 25 '14 at 19:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Have you tried doing sudo apt-get install --reinstall virtualbox-dkms at all? – dobey Jan 3 '14 at 20:00
  • Have you tried to start the module manually? sudo service virtualbox start It should start the service (if it's istalled for your kernel). If it tells you is not, try reinstalling virtualbox, it should build the module and reinstall it. – animaletdesequia Jan 3 '14 at 20:04
  • no I haven't but i will right now – Jfonts Jan 3 '14 at 20:39
  • yea i just tried it and it didn't work. invoke-rc.d: initscript virtualbox, action "restart" failed. – Jfonts Jan 3 '14 at 20:40
  • Did you try running sudo /etc/init.d/vboxdrv setup as the error message requested ? If so, what error message did you get ? – Panther Jan 3 '14 at 20:57
0

I had same problem running on Ubuntu 12.04 - it happened after last kernel update

I solved by re-installing virtual box

sudo dpkg -i virtualbox-4.3_4.3.6-91406 .. .deb

Not the answer you're looking for? Browse other questions tagged or ask your own question.