0

Yesterday I was looking online to see how can I transfer pictures,files from my Nexus 7 tablet to my desktop computer with the usb cable.. I've found several support forums like this one I'm using right now,someone has already asked a question like mine so I followed the best answer, I typed the commands in the terminal as the helper suggested,then I restarted my desktop pc,after that it didn't connect any more,it connects wireless usually,but since yesterday no connection:( I still have the page/link that shows the answer I've followed (the top one) : How do I connect a Nexus 7 to transfer files?

I'm also copying an pasting the answer I've followed :

''You have to follow a below procedure to share contents between Ubuntu to Nexus 7.

Install the necessary tools using terminal.

sudo apt-get install mtp-tools mtpfs 

Connect your Galaxy Nexus to your computer. On your phone, open up the notification drawer, and click on “USB Connection type”. Make sure that MTP is selected.

Type these commands in terminal:

mtp-detect | grep idVendor
mtp-detect | grep idProduct

The output of these commands should give you idVendor and idProduct. Note down the values given, as you'll need them later.

Run this command in terminal:

gksu gedit /etc/udev/rules.d/51-android.rules

A Gedit window should open. Simply Copy and paste below line.

SUBSYSTEM=="usb", ATTR{idVendor}=="VENDORID", ATTR{idProduct}=="PRODUCTID", MODE="0666"

Replace VENDORID and PRODUCTID with the idVendor and idProduct you had noted down earlier in Gedit.

Save and close the file. Then, disconnect your phone and run these commands:

sudo service udev restart
sudo mkdir /media/GalaxyNexus
sudo chmod a+rwx /media/GalaxyNexus
sudo adduser YOURUSERNAME fuse

Replace YOURUSERNAME with your Ubuntu user name. Now, run this command:

gksu gedit /etc/fuse.conf

In the Gedit window, remove the # at the beginning of the last line.

You’re almost done! Now, restart your computer, and then run these three commands:

echo "alias android-connect=\"mtpfs -o allow_other /media/GalaxyNexus\"" >> ~/.bashrc
echo "alias android-disconnect=\"fusermount -u /media/GalaxyNexus\"" >> ~/.bashrc
source ~/.bashrc

Again, do re-type the quotes in each command after you’ve copied, otherwise the command won’t work.

Connect your phone again, and then make sure your phone is using MTP, then run this command:

android-connect

You will able to connect the Nexus 7 your to your Ubuntu computer.''

after I did this and restarted my pc,I couldn't connect any more with wireless

0

Well, that's strange. You did nothing that can alter you Wireless connexion...

Option 1. Undo the source command :

Move the .bashrc and reboot

  • sudo chmod 777 ~/.bashrc
  • sudo mv ~/.bashrc ~/.bashrc.bkp
  • sudo reboot

When restarted, restore your .bashrc

  • sudo mv ~/.bashrc.bkp ~/.bashrc
  • sudo chmod +x ~/.bashrc

Restart and see if you have wireless connexion (don't count on it... but who knows?)

Option 2. Undo your manipulation :

  • gksu gedit /etc/fuse.conf : Add a # at the beginning of the last line
  • sudo mv /etc/udev/rules.d/51-android.rules /etc/udev/rules.d/51-android.rules.bkp
  • sudo service udev restart
  • sudo apt-get remove --purge mtp-tools mtpfs
  • sudo reboot

If still nothing... I really don't know what you did ^^


In the future, regarding your android tablet, if you have 13.04 or superior, it works out-of-the-box (tablet settings to MTP, disable USB debogging if activated)

If you have 12.10 or older, check : http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html http://www.webupd8.org/2012/12/how-to-mount-android-40-ubuntu-go-mtpfs.html

Note that Google uses a different protocol than other manufacturers. It uses go-mtpfs instead of mtpfs ('go' for 'google')

  • which # should I add at the beginning of the last line? – mediterranean Jan 4 '14 at 4:27
  • also I didn't follow all the steps on the link I attached..I stopped somewhere in the middle because I saw the connection was gone,then using my other computer and trying to fix this problem I searched for other commands and applied that on my disconnected desktop pc.. – mediterranean Jan 4 '14 at 4:29
  • I've tried with bios,and many other commands still nothing..for the state it says ''connecting'' but still nothing all day – mediterranean Jan 4 '14 at 4:30
  • can you post the return of ip link and iw dev ? And with the return of iw dev (likely wlp1s0 or similar), post the return of ip link show wlp1s0 – MrVaykadji Jan 4 '14 at 5:06
  • 1
    I didn't know I should have replaced the word USERNAME with my actual one,I just typed USERNAME:) I'm telling this in case someone does the same mistake.. – mediterranean Jan 4 '14 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.