7

Nokia Lumia 610 gets mounted but when I try to open the internal storage, it shows the following message:

Sorry, could not display all the contents of “Storage”: libmtp error: could not get object handles.

Installing libmtp or mtp applications from Ubuntu Software Center is not solving the problem.

11
  • Which libmtp or mtp applications did you install?
    – jobin
    Commented Jan 3, 2014 at 17:14
  • I installed gMTP from Ubuntu Software Center and libmtp 1.1.0 from sourceforge Commented Jan 3, 2014 at 17:19
  • 2
    Possible related Bug: bugs.launchpad.net/gvfs/+bug/1247572
    – Clausi
    Commented Jan 15, 2014 at 9:34
  • 2
    Clausi... This is about Windows Phone 7.8. Lumia 620 has Windows 8 OS. I am having problems with Lumia 610 Commented Jan 15, 2014 at 11:03
  • which ubuntu version are you using? Commented Jan 15, 2014 at 13:18

3 Answers 3

2

try to install gmtp from the Ubuntu Software center. It worked for my windows phone.

2
  • Which windows phone do you have..?? Commented Mar 3, 2014 at 13:45
  • Sorry for beign late, HTC Mozart
    – Daniel
    Commented Mar 7, 2014 at 15:45
0

I know this may not be exactly what you are looking for, but this was my solution to a similar problem; I've always had problems getting media devices to work with ubuntu via usb. My solution is to set up an ftp server on the phone/device and then use a good ftp client like FileZilla on your computer to access it. If you have a wlan at home then this works great out of the box. I don't know anything about Windows phones, but I'd be willing to bet there's an ftp sever app out there somewhere. It's actually easier sometimes to to it this way, no messing with wires, etc. I hope this helps.

0

I tried a fresh Ubuntu install and without installing any gtmp, mtp, libmtp tools, I was able to access storage and browse pictures. But not anything else. In a Lumia 610 either work with Skydrive or try using bluetooth transfer application for mp3, mp4 files. There is no other way, unless we get a Zune software for Ubuntu.

1
  • Please be more specific. What do you mean by "anything else"? Since 14.04 I can access the storage and SD card of my Lumia 620 just fine. Learn to address your issues, or things will never get fixed. A Zune software for Linux/Ubuntu from Microsoft that does nothing else than talk to the device via MTP will not happen, you can give your hopes up on that.
    – LiveWireBT
    Commented May 18, 2014 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .