0

while installing anything or updating i get this error "The installation or removal of a software package failed." and details are below :

installArchives() failed: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 445343 files and directories currently installed.)
Preparing to replace qbittorrent 3.1.x-0~4612-20131231~ubuntu12.04.1 (using .../qbittorrent_3.1.x-0~4619-20140103~ubuntu12.04.1_i386.deb) ...
Unpacking replacement qbittorrent ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for menu ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up isc-dhcp-server (4.1.ESV-R4-0ubuntu5.9) ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/var/lib/dpkg/info/isc-dhcp-server.config: 10: /etc/default/isc-dhcp-server: Separate: not found
dpkg: error processing isc-dhcp-server (--configure):
 subprocess installed post-installation script returned error exit status 127
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of dhcp3-server:
 dhcp3-server depends on isc-dhcp-server; however:
  Package isc-dhcp-server is not configured yet.
dpkg: error processing dhcp3-server (--configure):
 dependency problems - leaving unconfigured
Setting up qbittorrent (3.1.x-0~4619-20140103~ubuntu12.04.1) ...No apport report written because MaxReports is reached already

Processing triggers for menu ...
Errors were encountered while processing:
 isc-dhcp-server
 dhcp3-server
Error in function: 
Setting up isc-dhcp-server (4.1.ESV-R4-0ubuntu5.9) ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/var/lib/dpkg/info/isc-dhcp-server.config: 10: /etc/default/isc-dhcp-server: Separate: not found
dpkg: error processing isc-dhcp-server (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of dhcp3-server:
 dhcp3-server depends on isc-dhcp-server; however:
  Package isc-dhcp-server is not configured yet.
dpkg: error processing dhcp3-server (--configure):
 dependency problems - leaving unconfigured

while in actual software gets installed but gives the above error. i am using ubuntu 12.04 with gnome shell.

1

1 Answer 1

0

From the error log in your question I can assume that something wrecked is happening with your locales. (an not only).

Examine this file

cat /etc/default/locale 

the content of this file should read

LANG="en_US.UTF-8" 

above is for English language. But no other line should be inside this file.

If other lines exist, edit the file and remove them all except from the LANG string.

If the file does not even exist then, create it and add the LANG string only.

In any case use an editor with root privileges.

gksudo gedit /etc/default/locale 

after you edit and save, reconfigure some things.

sudo dpkg-reconfigure locales 
sudo update-locale 

logout/login or reboot.

About the dhcp server, read this answer. Some configuration files must exist. These files are listed in the answer with the default content.

Then try again

sudo apt-get install -f
sudo dpkg --configure -a

Not the answer you're looking for? Browse other questions tagged or ask your own question.