2

I have tried the solution as presented here What to do about "the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present"? as well as its original source http://punygeek.blogspot.com/2012/10/ubuntu-1204-how-to-solve-disk-drive-for.html here several times.

What's happening is that every time I reformat my linux-swap with Gparted, it works perfectly well as long as my session lasts. Whenever I reboot, the swap partition becomes "unknown" as displayed in Gparted, needless to say “the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present” is still present.

  • I am still having the problem after running the Punygeek process - it works up to the point where I reboot the system, then comes back with the same error again, and Gparted reports that the linux-swap partition goes back to being unknown. – user293526 Jun 14 '14 at 16:31
2

Try this if on 12.04, probably work for other distros too. Already answered here:

"Disk drive for dev/mapper/cryptswap 1 is not ready"

You could also look here:

http://punygeek.blogspot.nl/2012/10/ubuntu-1204-how-to-solve-disk-drive-for.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.