Some time ago I installed xorg edgers nvidia 331 drivers for my Nvidia 420M with Ubuntu 13.10.

Today I have run as usual

sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y

And since then my laptop always boots into low-graphics mode prompt to ask whether to troubleshoot the problem, check logs, etc. but even after marking boot into low graphics mode it never does (it hangs in x but I can still CtrlAltF1-6. I have uninstalled my graphics drivers after that, reinstalled them (the same effect). Removed xorg edgers PPA, installed nvidia-319 drivers (the same).

Always low-graphics mode.

I have also had problems with 3.12 kernel that I have installed (manually from kernel.org but after I have completely removed them and upgraded GRUB; there is now problem with the drivers.)

I attach Xorg.0.log

[     9.912] 
X.Org X Server 1.14.5
Release Date: 2013-12-12
[     9.912] X Protocol Version 11, Revision 0
[     9.912] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
[     9.912] Current Operating System: Linux icanseeyou 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64
[     9.912] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=cd852128-b5f9-4c66-82c0-08ffd489da5d ro persistent quiet splash
[     9.912] Build Date: 17 December 2013  10:06:15AM
[     9.912] xorg-server 2:1.14.5-1ubuntu2~saucy1 (For technical support please see http://www.ubuntu.com/support) 
[     9.912] Current version of pixman: 0.30.2
[     9.913]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[     9.913] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     9.913] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  2 22:53:36 2014
[     9.913] (==) Using config file: "/etc/X11/xorg.conf"
[     9.913] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     9.913] (==) ServerLayout "Layout0"
[     9.913] (**) |-->Screen "Screen0" (0)
[     9.913] (**) |   |-->Monitor "Monitor0"
[     9.913] (**) |   |-->Device "Device0"
[     9.913] (**) |-->Input Device "Keyboard0"
[     9.913] (**) |-->Input Device "Mouse0"
[     9.913] (==) Automatically adding devices
[     9.913] (==) Automatically enabling devices
[     9.913] (==) Automatically adding GPU devices
[     9.913] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     9.913]    Entry deleted from font path.
[     9.913] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[     9.913]    Entry deleted from font path.
[     9.913] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     9.913]    Entry deleted from font path.
[     9.913] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[     9.913]    Entry deleted from font path.
[     9.913] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     9.913]    Entry deleted from font path.
[     9.913] (==) FontPath set to:
[     9.913] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[     9.913] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[     9.913] (WW) Disabling Keyboard0
[     9.913] (WW) Disabling Mouse0
[     9.913] (II) Loader magic: 0x7fd9888bfd20
[     9.913] (II) Module ABI versions:
[     9.913]    X.Org ANSI C Emulation: 0.4
[     9.913]    X.Org Video Driver: 14.1
[     9.913]    X.Org XInput driver : 19.1
[     9.913]    X.Org Server Extension : 7.0
[     9.914] (--) PCI:*(0:1:0:0) 10de:0df1:1025:0487 rev 161, Mem @ 0xb2000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[     9.915] (II) Open ACPI successful (/var/run/acpid.socket)
[     9.915] Initializing built-in extension Generic Event Extension
[     9.915] Initializing built-in extension SHAPE
[     9.915] Initializing built-in extension MIT-SHM
[     9.915] Initializing built-in extension XInputExtension
[     9.915] Initializing built-in extension XTEST
[     9.915] Initializing built-in extension BIG-REQUESTS
[     9.915] Initializing built-in extension SYNC
[     9.915] Initializing built-in extension XKEYBOARD
[     9.915] Initializing built-in extension XC-MISC
[     9.915] Initializing built-in extension SECURITY
[     9.915] Initializing built-in extension XINERAMA
[     9.915] Initializing built-in extension XFIXES
[     9.915] Initializing built-in extension RENDER
[     9.915] Initializing built-in extension RANDR
[     9.915] Initializing built-in extension COMPOSITE
[     9.915] Initializing built-in extension DAMAGE
[     9.915] Initializing built-in extension MIT-SCREEN-SAVER
[     9.915] Initializing built-in extension DOUBLE-BUFFER
[     9.915] Initializing built-in extension RECORD
[     9.915] Initializing built-in extension DPMS
[     9.915] Initializing built-in extension X-Resource
[     9.915] Initializing built-in extension XVideo
[     9.915] Initializing built-in extension XVideo-MotionCompensation
[     9.915] Initializing built-in extension SELinux
[     9.915] Initializing built-in extension XFree86-VidModeExtension
[     9.915] Initializing built-in extension XFree86-DGA
[     9.915] Initializing built-in extension XFree86-DRI
[     9.915] Initializing built-in extension DRI2
[     9.915] (II) "glx" will be loaded by default.
[     9.915] (WW) "xmir" is not to be loaded by default. Skipping.
[     9.915] (II) LoadModule: "dri2"
[     9.915] (II) Module "dri2" already built-in
[     9.915] (II) LoadModule: "glamoregl"
[     9.916] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    10.024] (II) Module glamoregl: vendor="X.Org Foundation"
[    10.024]    compiled for 1.14.3, module version = 0.5.1
[    10.024]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.024] (II) LoadModule: "glx"
[    10.024] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    10.071] (II) Module glx: vendor="NVIDIA Corporation"
[    10.071]    compiled for 4.0.2, module version = 1.0.0
[    10.071]    Module class: X.Org Server Extension
[    10.071] (II) NVIDIA GLX Module  319.60  Wed Sep 25 14:24:11 PDT 2013
[    10.071] Loading extension GLX
[    10.071] (II) LoadModule: "nvidia"
[    10.071] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    10.085] (II) Module nvidia: vendor="NVIDIA Corporation"
[    10.085]    compiled for 4.0.2, module version = 1.0.0
[    10.085]    Module class: X.Org Video Driver
[    10.091] (II) NVIDIA dlloader X Driver  319.60  Wed Sep 25 14:04:14 PDT 2013
[    10.091] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    10.092] (++) using VT number 7

[    10.096] (II) Loading sub module "fb"
[    10.096] (II) LoadModule: "fb"
[    10.096] (II) Loading /usr/lib/xorg/modules/libfb.so
[    10.097] (II) Module fb: vendor="X.Org Foundation"
[    10.097]    compiled for 1.14.5, module version = 1.0.0
[    10.097]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.097] (WW) Unresolved symbol: fbGetGCPrivateKey
[    10.097] (II) Loading sub module "wfb"
[    10.097] (II) LoadModule: "wfb"
[    10.097] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    10.100] (II) Module wfb: vendor="X.Org Foundation"
[    10.100]    compiled for 1.14.5, module version = 1.0.0
[    10.100]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.100] (II) Loading sub module "shadow"
[    10.100] (II) LoadModule: "shadow"
[    10.100] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    10.101] (II) Module shadow: vendor="X.Org Foundation"
[    10.101]    compiled for 1.14.5, module version = 1.1.0
[    10.101]    ABI class: X.Org ANSI C Emulation, version 0.4
[    10.101] (II) Loading sub module "ramdac"
[    10.101] (II) LoadModule: "ramdac"
[    10.101] (II) Module "ramdac" already built-in
[    10.103] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    10.103] (==) NVIDIA(0): RGB weight 888
[    10.103] (==) NVIDIA(0): Default visual is TrueColor
[    10.103] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    10.103] (**) NVIDIA(0): Enabling 2D acceleration
[    10.109] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[    10.109] (EE) NVIDIA(0):     system's kernel log for additional error messages and
[    10.109] (EE) NVIDIA(0):     consult the NVIDIA README for details.
[    10.109] (EE) NVIDIA(0):  *** Aborting ***
[    10.109] (EE) NVIDIA(0): Failing initialization of X screen 0
[    10.109] (II) UnloadModule: "nvidia"
[    10.109] (II) UnloadSubModule: "shadow"
[    10.109] (II) UnloadSubModule: "wfb"
[    10.109] (II) UnloadSubModule: "fb"
[    10.109] (EE) Screen(s) found, but none have a usable configuration.
[    10.109] (EE) 
Fatal server error:
[    10.109] (EE) no screens found(EE) 
[    10.109] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    10.109] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    10.109] (EE) 
[    10.110] (EE) Server terminated with error (1). Closing log file.

My installed Linux kernel and headers

ii  linux-generic                                                     amd64        Complete Generic Linux kernel and headers
ii  linux-headers-3.11.0-15                3.11.0-15.23                                     all          Header files related to Linux kernel version 3.11.0
ii  linux-headers-3.11.0-15-generic        3.11.0-15.23                                     amd64        Linux kernel headers for version 3.11.0 on 64 bit x86 SMP
ii  linux-headers-generic                                             amd64        Generic Linux kernel headers
ii  linux-image-3.11.0-15-generic          3.11.0-15.23                                     amd64        Linux kernel image for version 3.11.0 on 64 bit x86 SMP
ii  linux-image-extra-3.11.0-15-generic    3.11.0-15.23                                     amd64        Linux kernel extra modules for version 3.11.0 on 64 bit x86 SMP
ii  linux-image-generic                                               amd64        Generic Linux kernel image

Installed nvidia packages

ii  nvidia-319-updates                     319.60-0ubuntu1                                  amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings-319-updates            319.60-0ubuntu1                                  amd64        Tool for configuring the NVIDIA graphics driver



  • 1
    can you post the output of dmesg as well? (I ask because it says to check the systems kernel log, and I believe dmesg covers that) – user1974 Jan 2 '14 at 22:24
  • @user1974 I have updated my question. Please take a look. – Patryk Jan 2 '14 at 22:31
  • 2
    It's not a duplicate, since I had exactly the same problem with this same upgrade this afternoon, and the solution in the other question doesn't work. This is an specific problem with this specific version of the drivers. – animaletdesequia Jan 2 '14 at 22:49
  • I had the same problem. I've solved it by installing nvidia 331. – mrroboaat Feb 19 '14 at 20:43

I had this same problem just a few hours ago, the latest 331 is broken. Downgrading to the previous driver or any other, included the open-source nouveau won't work, the only solution is uninstall all nvidia packages and install the driver from the .run you can download from the nvidia website.


There, select your graphic card, architecture, etc, and download the installer. When it's done, you'll need to install it from the commandline without X running. Pres Ctrl+Alt+F6 and after login:

sudo service lightdm stop
sudo apt-get remove nvidia-319 nvidia-331 # (change this line to match the drivers you have installed).

Now, asuming your driver has been downloaded to the "Downloads" folder:

cd Downloads
chmod +x NVIDIA*
sudo ./NVIDIA*.run

I've used the asterisk here because I can't know if the driver you downloaded is the exact same name as mine, since it depends on your GPU. You could use autocompletion with the tab key to use the exact .run name.

Follow the on screen instructions. When you finish, reboot:

sudo shutdown -r now

If after rebooting you see the same problem, log again in a TTY and try:

sudo nvidia-xconfig

This should regenerate a new /etc/X11/xorg.conf

Just a quick update for anyone who used my solution: Today a new update of some gl libraries has broken my system again. I've had to re-install the NVIDIA run package, it complained about some of its libraries being altered and restored them to its working state. There seems to be a compatibility problem between libraries from the official repositories and the ones packaged in the driver. This is the reason I don't like to install things from outside packagers... To reinstall the driver, kill the X with

sudo service lightdm stop

and reinstall the .run with

sudo ./NVIDIA....run 
  • 1
    I get the following error on installing from these drivers : -> Installing NVIDIA driver version 331.20. -> Running distribution scripts executing: '/usr/lib/nvidia/pre-install'... -> done. -> The distribution-provided pre-install script failed! Continue installation anyway? (Answer: No) – Patryk Jan 2 '14 at 23:08
  • 1
    I forgot to tell you that, I got exactly the same message. First I choosed No out of caution, but then when I was about to give up and reinnstall the whole system, I've tried again and selected yes to continue anyway, and the installation finished OK. – animaletdesequia Jan 2 '14 at 23:11
  • Did the same and now I booted back to the system :) Thanks. – Patryk Jan 2 '14 at 23:12
  • 1
    Glad it helped. I was planing to spend today gaming and because of this, I've been hitting my head against the PC the whole day. Just remember one thing, your drivers are now installed from a source outside the package system, so if you later decide to install drivers from xorg-edgers or the official ppa's, you'll have to first uninstall this driver manually. If you try to use apt-get or the software-center to overwrite this drivers, it could break the configuration. – animaletdesequia Jan 2 '14 at 23:15
  • 1
    Just a quick update: I just restarted the system after upgrading some packages and it was broken again. Aparently, a new version of xserver-xorg-video-nouveau broke the nvidia driver installed manually. If this happens to you, since you said you were trying different drivers, just remove it with sudo apt-get remove xserver-xorg-video-nouveau and reboot. It should load again the privative drivers. – animaletdesequia Jan 3 '14 at 19:30

It's Bumbleebee. Bumblebee blacklists the nvidia-driver. So Ubuntu is trying to load drivers at start up, but they are blacklisted. Uninstalling Bumblebee helped me.

  • 1
    +1 I experienced the same issues after the update from xorg-edgers and uninstalling bumblebee corrected the issue. – matt davis Jan 4 '14 at 23:10
  • This helped me too, uninstalling bumblebee solved everything. – Stefan Radovanovici Jan 6 '14 at 13:56
  • Thank you so much! I was trying to fix this for 4 hours. Uninstalling bumblebee fixed it. – EmbMicro Jan 9 '14 at 17:26
  • 1
    Don't forget to purge or bumblebee won't remove the blacklist! – Ethereal Jan 17 '14 at 16:40
  • This also resolved my issue. "sudo apt-get purge bumblebee". Bumblebee has been nothing but problematic for me. This worked for me with Ubuntu 14.04. – mrinterweb Apr 18 '14 at 7:04

I had the exact same problem since 2 days ago after an upgrade of nvidia-331 package (331.20-0ubuntu8~xedgers~saucy1).

I then tried a few approaches, eg. ppa-purge, using the official nvidia-current, nvidia-319 from ubuntu repositories. However it could not automatically start up graphical interface properly (always say to run in low resolution mode then hung if I continued), I needed to exit to console mode and type below in order to restore the graphical interface,

sudo modprobe nvidia-<ver>
sudo lightdm start

Then I just tried using the x-swat package (instead of xedgers) as the xedgers webpage said it is supposed a more stable package.

I installed the nvidia-331 again (but different minor version 331.20-0ubuntu1~xedgers~saucy1) and then it now can load up the graphical interface automatically on startup.

It may be due to related packages being added / configured again while I installed the x-swat nvidia-331 package, the root cause may not be within the nvidia-331 package itself, but at least I now can get it back to normal startup.

It may worth a try.

  • I wanted to try x-swat as well but then I used darent's answer and installed the drivers from .run file. – Patryk Jan 4 '14 at 13:44

The same happened to me after upgrading my Ubuntu 13.10 installation on a Thinkpad W520 with dual graphic cards on 2014-01-05. The upgrade included the nvidia-331-driver (331.20-0ubuntu1~xedgers~saucy1) from the xorg-edgers PPA.

Purging and reinstallation of unity-greeter, lightdm, xorg, xserver-xorg, linux-headers and downgrade to nvidia-current or nvidia-current-updates and switching to gdm had no effect.

The problem is definitely with bumblebee, which seems to be bundled with nvidia-331 in that specific upgrade. The computer will not return to normal condition until bumblebee has been removed.

Just in case you already messed with your drivers, here is a somewhat elaborate procedure to fix the problem:

From the "The system is running in low-graphics mode"-screen press Ctrl-Alt-F1 to get a terminal and log in. Alternatively you can start your system with shift-key pressed, choose recovery mode, activate networks and go to root shell.

sudo apt-get purge nvidia-*
sudo apt-get purge bumblebee*
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install nvidia-331
sudo apt-get remove --purge bumblebee

If you have messed with the nvidia-packages and the X11-config file(s) before, it might be necessary to backup all xorg.conf-files, then delete them and create a fresh one:

sudo cp /etc/X11/xorg.conf* ~/YOURBACKUPDESTINATION/
sudo rm /etc/X11/xorg.conf*
sudo nvidia-xconfig

Finally restart your computer and it should be fine:

sudo reboot

Keep in mind that the "The system is running in low-graphics mode"-problem can have many reasons and this solution is covering only one possible reason - the bumblebee-infested upgrade of nvidia-331.

Also keep in mind, that the problem could re-occur on future upgrades, so make sure, bumblebee is not installed next time you upgrade the nvidia-driver.


See the following bug https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1265570

The reason that ppa-purge or downgrading the nvidia driver doesn't work is that /etc/modprobe.d/bumblebee.conf is still left behind.


I can confirm that Bumblebee is causing the problem. Looking at the bumblebee config file in /etc/modules.d shows that it has blacklisted the nvidia-331 module. This is probably a recent change to bumblebee. Removing bumblebee by using the following commandline fixes the issue:

apt-get purge bumblebee 

Obviously you should only do this if you are not actually using the bumblebee module (which if you are using the nvidia drivers you probably aren't).

This problem affects all nvidia drivers up to version 311


Similar to issues mentioned above, I also had a fight with an Ubuntu 13.10 system after upgrading 2 days ago. Even running the officual NVIDIA installer didn't help.

This is from memory so please excuse the lack of exact detail.

I had another 13.10 system working fine with a couple of differences. The nvidia-331 and the kernel are both being "kept back". So I figured I needed to ensure the kernel and nvidia-331 packages were like this working system.

My solution was to uninstall all nvidia packages apt-get remove --purge nvidia*

Uninstall kernel 3.11.0-15-generic etc.

Install kernel 3.11.0-14-generic (3.11.0-14.21) and linux-headers-3.11.0-14

Next, I needed the earlier versions of the Xedgers packages. I googled each of these packages and grabbed them from launchpad.net nvidia-331_331.20-0ubuntu1~xedgers~saucy1_amd64.deb nvidia-persistenced_331.20-0ubuntu1~xedgers~saucy1_amd64.deb nvidia-settings-331_331.20-0ubuntu1~xedgers~saucy1_amd64.deb

apt-get install nvidia-common Then install the Xedgers packages above.... (dpkg -i package.deb)

I ran into some dependency issues, and it wanted to upgrade nvidia-331 to the later Xedgers package - not what we want - I'm a little hazy on exactly what I did but I ran aptitude and put the package nvidia-331 on hold (press the "=").

I think I still had to "apt-get -f install" after this. Not sure.

All going well, DKMS should spit out a driver for kernel 3.11.0-14. That is, there should be a file "nvidia_331.ko" in: /lib/modules/3.11.0-14-generic/updates/dkms

If there is not, I guess "dpkg-reconfigure nvidia-331" should again go through the DKMS process.

The end result from "dpkg -l |grep nvidia"

ii nvidia-331 331.20-0ubuntu1~xedgers~saucy1 amd64 NVIDIA binary Xorg driver, kernel module and VDPAU library ii nvidia-common 1:0.2.83 amd64 transitional package for ubuntu-drivers-common ii nvidia-persistenced 331.20-0ubuntu1~xedgers~saucy1 amd64 Load the NVIDIA kernel driver and create device files ii nvidia-settings-331 331.20-0ubuntu1~xedgers~saucy1 amd64 Tool for configuring the NVIDIA graphics driver

The last thing, possibly unrelated, was that there was no xorg.conf in /etc/X11 for some reason. "service lightdm stop" wasn't doing anything yet I would see X related processes referencing "lightdm" and "failsafe".

I moved /etc/X11/xorg.conf.failsafe to /etc/X11/xorg.conf.failsafe.backup. There were backups of earlier xorg.conf files from the upgrade process, so I copied one of those as /etc/X11/xorg.conf.

All sorted.

I repeated this process on another system and did not encounter the Xorg.conf issue.

I hope my comments here help someone out.


protected by Community Jan 14 '14 at 1:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.