3

This question already has an answer here:

After my update from 12.04 to 13.10 my display configuration started showing an extra unknown monitor, even though I have nothing connected.

enter image description here

lscpi:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)

xrandr

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       60.0*+   60.1  
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
VGA-2 connected (normal left inverted right x axis y axis)
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
  1024x768 (0x43)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x44)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x45)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

This problem seems to had been previously asked here and here.

Any ideas on how to solve this?

marked as duplicate by Eric Carvalho, Charles Green, Elder Geek, mikewhatever, s3lph Jan 1 '15 at 23:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

I have finally found a working solution in these two questions: one, two

Basically one needs to edit sudo gedit /etc/default/grub and replace

GRUB_CMDLINE_LINUX=""

by

GRUB_CMDLINE_LINUX="video=VGA-2:d"

where VGA-2 is the name of the incorrectly connected display shown by xrandr.

Run

sudo update-grub

and reboot

  • Same NVIDIA issue. :( For me, it's named VGA-1-2. Above solution didn't work out of the box due to uncertain reason, so here is what additional things I performed to disable that 'Unknown Display' in Ubuntu GNOME 14.04. Removed entries respected toVGA-1-2 from config file ~/.config/monitors.xml and executed below command to disable all VGA as I don't use any VGA. echo xrandr --output vga --off >> ~/.xinitrc and finally sudo reboot :) – Mayura May 6 '14 at 2:30
0

Yeah this happened with me on my fresh ubuntu 13.10 install, no idea why, I disable it and it works fine. it pops back up when connecting a secondary monitor to my laptop but just disable it again. I think its a display driver issue

Not the answer you're looking for? Browse other questions tagged or ask your own question.