I recently installed Ubuntu 12.04 32 bit in my Toshiba T110 laptop, and the brightness control doesn't work.

I have tried gedit /etc/default/grub, and have modified the "quite splash" to many suggestion that i have come across, like:

"quiet splash acpi_backlight=vendor" and "quiet splash acpi_osi=Linux" and "quiet splash acpi_osi=Linux acpi_backlight=vendor"

but nothing seems to work, I mean i can see the brightness indicator moving but the brightness is set to highest all the time, Please help.

2 Answers 2


you can try below command

xrandr --output LVDS1 --brightness 0.89
  • Thanks for the answer David, I ran the line and here what I've got: xrandr --output LVDS --brightness 0.89 warning: output LVDS not found; ignoring xrandr: Need crtc to set gamma on.
    – user163507
    Jan 2, 2014 at 14:52
  • xrandr first , and chose your device id(may be VGA***)
    – David
    Jan 3, 2014 at 5:14
  • I realy appreciate your help David, any suggustions
    – user163507
    Jan 5, 2014 at 15:28
  • replace LVDS to LVDS1 is ok
    – David
    Jan 7, 2014 at 5:34

I got this to work running the following:

first I updated the kernel with the line sudo apt-get install linux-image-generic-lts-quantal

then I updated the x stack with the line sudo apt-get install xserver-xorg-lts-quantal

after that I ran sudo gedit /etc/default/grub I modified where it says "quite splash" to "quiet splash acpi_backlight=vendor" saved it.

updated grub using sudo update-grub , rebooted the system and now the "FN" works like magic

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .