EDIT: SOLVED! see https://askubuntu.com/a/403876/212688

i re-installed ubuntu 13.10 x64 on my vaio pro, in legacy, bios mode. the installation is lvm/luks encrypted and thus asks me for the encryption password before booting.

it does not reliably boot. i often have to try several times, those are the errors i get:

... alert! /dev/mapper/ubuntu-vg-root does not exist ...

enter image description here and sometimes it "boots" without asking me for the password and then fails with cryptsetup: cvms_activate is not available

enter image description here

this happened on my old install, i fully wiped the ssd and the problem still persists. how can i fix this?

and does anyone have an idea, why booting takes over one minute? the pci-e samsung ssd reads with around 800MB/s that should boot in 15 seconds or less.

my macbook with a slow sata3 ssd boots in 20 seconds, with full disc encryption.


i didn't mention it before, but i used the defaults of the installer and didn't create my own partition layout. just install with internet and getting updates during the install, reboot into system, install updates and then i had the error, again, like in my previous install.


I have been following this problem(or a variation of), that I also have, for about a year. The only way I can even boot is with a very old kernel. This is an unsolved bug going on 2 years ( https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1003309 ). Some people have fixed this problem, it usually entails major surgery into the bowels of your system ;), your mileage may vary. None have worked for me and I am reluctant to do something like reinstall kernels, when every kernel I have installed in a year has not worked. May I suggest that the complexity of the boot system itself is the problem. If you want to throw something else in there, like encrypting your disk, you are just asking for trouble. So here is my solution:

  1. Remove disk encryption. reinstall or follow this guide How to stop using built-in home directory encryption?

  2. To encrypt your data use the program Cryptkeeper. This is an excellent, elegant program that doesn't muck up anything else on your system. In other words it is everything disk encryption is not!

I doubt that an easier or more reliable solution will show up here.

  • thanks, not good to hear. i want full disk encryption, other options are not a solution. it's really weird, that it boots sometimes just fine. i'm looking at the bug now. – vaioonbuntu Jan 1 '14 at 19:03

solved it. forgot that i did this with my first install: edit the grub cfg: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=noncq" then sudo update grub, or something like that to write the change. this fixed the boot trouble and also decreases the startup time from over one minute to 15 seconds from pressing power.

here's a good compilation of fixes, needed for the vaio pro: http://steffankarger.nl/2013/12/10/ubuntu-13-10-on-the-sony-vaio-pro-13/


We think the problem is that the OS didn't install properly.


  1. Reinstall Ubuntu OS with you favorite. (Select full disk encryption.)
  2. If that does not work just backup and select "Erase Disk and Install Ubuntu 13.10" in Install Type with you favorite also. (Select full disk encryption.)
  • 1
    Welcome to Ask Ubuntu! The author of this question had the problem, wiped their disk, installed again, and had the problem again, at least if I am correctly understanding the question, which says, "this happened on my old install, i fully wiped the ssd and the problem still persists." (That seems to cover both your suggestions.) If you still believe a reinstall may fix this, I recommend editing your answer to explain why or exactly what should be done differently. – Eliah Kagan Jan 11 '14 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.