10

I need the character Cedilla working my English USA Ubuntu Natty but when use the normal combination ' then c I get this ć. In the previous versions I used this solution: [SOLVED] Getting ç cedilla instead of c acute with american keyboards but it isn't working on Natty. Any help will be very appreciatted! Best regards.

1
  • Did you try gksudo gedit /usr/lib/gtk-2.0/2.10.0/gtk.immodules – wojox May 3 '11 at 22:35
8

Bug reference: #518056

Answer from Hélio José:

For 64-bit systems:

sudo -H gedit /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache
sudo -H gedit /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache

For 32-bit systems:

sudo -H gedit /usr/lib/i386-linux-gnu/gtk-2.0/2.10.0/immodules.cache

Change the line

"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"

to

"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"

Replace "ć" with "ç" and "Ć" with "Ç" in /usr/share/X11/locale/en_US.UTF-8/Compose

sudo cp /usr/share/X11/locale/en_US.UTF-8/Compose /usr/share/X11/locale/en_US.UTF-8/Compose.bak
sed 's/ć/ç/g' < /usr/share/X11/locale/en_US.UTF-8/Compose | sed 's/Ć/Ç/g' > Compose
sudo mv Compose /usr/share/X11/locale/en_US.UTF-8/Compose

Add two lines in /etc/environment

GTK_IM_MODULE=cedilla
QT_IM_MODULE=cedilla

Restart your computer.

1
  • the step 3 is the only needed for the most recent ubuntu releases - 13.10 and 14.04 – igorsantos07 Nov 19 '14 at 18:02
3

Choose keyboard = USA international with dead keys

Try Keyboard>layout>options>Key to choose 3rd level> right ctrl

then try right ctrl + <, press first the right ctrl and keep it pressed, then

with another finger press <

1
  • by default this behavior in any other setting is of right alt (aka AltGr). Thus, there's no need to change this setting and instead you can simply use AltGr + comma – igorsantos07 Nov 19 '14 at 16:26
1

If you're in a hurry, do this and you'll get "ç" instead of "ć":

Press "AltGr + ," then "c".

If you want to know a bit more, keep on reading.

This may be solved already by using one of the answers above, but I realized the best thing to do is use the keyboard layout, instead of changing things you'll have to eventually change again in the future (after updates, for example).

Before I start, keep in mind I'm using Ubuntu 14.04.2, which is not the same distro as the original question mentions (11.04). Anyway, I believe most users migrated to newwer versions by now. So:

$ cat /etc/issue
Ubuntu 14.04.2 LTS \n \l

Okay, the first thing I did was looking at the immodules files:

/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache

At the header, those files clearly mention they should not be changed, since they're generated automatically:

# GTK+ Input Method Modules file
# Automatically generated file, do not edit
# Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.10.8

So changing them, although it may solve the problem temporarily, is not ideal.

Looking around, I found the best answer ever about why we get a "ć" instead of a "ç" when typing ' + c: because we're really putting an acute accent on the top of letter "c". So the layout is right. With that in mind, how would one put a "kind of a" comma at the bottom of the "c" letter? Using a comma, of course!

So, the solution was the key combination AltGR + , and then "c".

No need for changing any configuration on your computer.

0

Using the Character Map you can copy and paste the character.

Character Map: Ced

0

Use ibus to provide you with these special characters. You will need to install the compose extension to ibus from the software centre or synaptic.

Not the answer you're looking for? Browse other questions tagged or ask your own question.