I upgraded my 10.04 system to 10.10 on my way to 11.04. I didn't try VMPlayer on 10.10, but it worked on 10.04.

I tried to start a VM in 11.04, and it prompted me to install the VMWare bits into the kernel. It would fail, and provide a log file. The log file looked normal until the end, at which point it said:

"Failed to compile module vmmon"

I found a number of references on the web for that, but all related to older versions of the kernel. The one I found for 2.6.38-8 was this patch:

VMware-player on Ubuntu 11.04 kernel 2.6.38-8

but that is for 64 bit. I assume those header patches won't work on 32 bit (yes?)


To answer my own question, the solution I used was to uninstall the old version, and install 3.1.4 from the VMWare site.

  1. sudo vmware-installer -u vmware-player
  2. sudo rm -rf /usr/lib/vmware
  3. Download and install VMPlayer 3.1.4
  • This is the precise solution - VMware Player 3.1.4. – Nicolay Doytchev Jul 17 '11 at 15:13

The attached file says:
VMplayer_3.0.0-203739.x86_64_2.6.38-8.tar.gz (3.1 K)
x86 means 32 bits system, ASFAIK. So you could try with this file. The other option is to run older kernel. I usually try with stable releases from here:
Mainline kernel downloads
BTW, I dont see 2.6.38-8 kernel there, is this the rc8 version?
I hope at least some of this info helps

  • Ah, you might be right that the package will work for 32bit. I didn't try that, so I can't confirm if that solution works. As for the kernel version, my install of 11.04 laid down 2.6.38-8-generic-pae. – Peter Laird May 5 '11 at 9:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.