2

I installed LXDE, but it seems the default theme (ClearLooks) doesn't work for Transmission, which is a gtk3 app.

All the themes I see in the Appearance tool are either gtk2, or gtk3, but not both.

What should I do to make both gtk2 and gtk3 apps look good in LXDE?

  • Could you please explain what your OS is, what command you used to install "LXDE", and what themes were listed (other than Clearlooks)? – user25656 Dec 30 '13 at 16:33
  • I've already installed a lot of themes on my computer, including Ambiance, and I have no idea which were there initially, and which were installed by me. As for the OS, it's Lubuntu. – sashoalm Dec 30 '13 at 17:09
  • Then you should have a theme called Lubuntu-default and I'm pretty sure that that supports both gtk2 and gtk3. I was wondering because you mentioned Clearlooks and that theme is only gtk2. Generally, older themes will be only gtk2 and most themes developed recently will be both. – user25656 Dec 30 '13 at 17:13
  • Please don't ask essentially the same question in more than one Stack Exchange site. – user25656 Dec 31 '13 at 2:21
1

Install a theme that has both gtk2 and gtk3. For example, sudo apt-get install shimmer-themes will get you a few themes which support both gtk2 and gtk3. There's also light-themes which will get you Ambiance and Radiance.
Incidentally, these themes will work whether you use LXDE or XFCE or Unity.
When you install these themes, they will pull in the necessary gtk engines which you may not have at the moment. You can see what you will get by using the -s flag along with sudo apt-get install or by running apt-cache show _package-name_.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.