9

When I try and open a file I downloaded in Chromium, it opens in a text editor. (Geany) I click on the arrow in the download bar and select "Show in folder".

I'm using Chromium daily stable and ubuntu 11.04 (although this was a problem previously under ubuntu 10.10) with Gnome.

I'm not sure where the breakdown is happening. In Chromium, ubuntu or maybe Geany has taken something hostage. Anyone having a similar problem?

Thanks,

1 Answer 1

18

That's pretty weird and annoying. I hope I can help you a bit into the correct direction :-)

Does it happen with any file type? txt? torrent? mp3?

  • In ~/.local/share/applications/mimeapps.list there is a list of files to be opened by an application. Have a look with more ~/.local/share/applications/mimeapps.list and check if you can find something weird here.

  • There is a nifty command, mimeopen, that allows you to alter what program should open what file (and that updates the file I mentioned before). It will "guess" what would be the most logical option based on the file you feed it.

Examples:

$ mimeopen -d /home/{your_name}/Documents
Please choose a default application for files of type inode/directory

    1) Open Folder  (nautilus-folder-handler)
    2) Other...

$ mimeopen -d \[Mazui\]_Ore_No_Imouto_-_14_\[SD\]\[7EA51F50\].mkv 
Please choose a default application for files of type video/x-matroska

    1) Enqueue in SMPlayer  (smplayer_enqueue)
    2) Movie Player  (totem)
    3) SMPlayer  (smplayer)
    4) Banshee  (banshee)
    5) VLC media player  (vlc)
    6) Other...

If it is a problem regarding mimetypes, this should solve it.

4
  • Thanks, I looked in mimeapps.list and found this line: inode/directory=geany.desktop;jedit.desktop; After commenting it out, things returned to normal. Thanks!
    – Dave
    May 3, 2011 at 19:04
  • 1
    That is a nifty command. I like it.
    – Oli
    Jul 26, 2011 at 13:21
  • 1
    I have this problem but this command did not help. I was able to change the default but the application that's actually opening was not even the list
    – endolith
    Jul 1, 2016 at 15:16
  • 1
    mimeopen did the trick, however I found it funny that I couldn't find anything weird on the mimeapps.list files I found. I did for f in $(locate mimeapps.list); do sudo egrep "(inode)|(code\.desktop)" $f && echo "-> $f" ; done but nothing stood out. However, after the problem was solved by using mimeopen, I ran the one liner again and it turned out ~/.config/mimeapps.list had been updated with the option I selected. I guess the problem was no option for inode/directory was set. Anyway +1. This helped me a lot, I was going crazy.
    – Samuel
    Dec 26, 2020 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.