I tried to install Xubuntu 13.10 on an older computer. I noticed some difficulties during installation that may be relevant to my problems. Notably:

  1. The screen resolution was extremely low. The windows were much larger than the screen and I had to move them around to get to the "Next" button.

  2. The mouse cursor was a blur of colours that was flashing all the time.

The installation finished and I tried to reboot the computer. Immediately I got:

error: attempt to read or write outside of disk 'hd0'. 
Entering rescue mode... 
grub rescue>

I made a Boot Repair USB disk, booted it and chose the default repair. The application told me that the problem is repaired and that If this does not solve my problem I should show this link to someone who can help me.

What should I do next? I already tried to install Ubuntu and Xubuntu, both with no success.

EDIT:

I found a workaround.

  1. Insert the Xubuntu live USB
  2. Select "try Xubuntu"
  3. In the settings menu select "install Xubuntu"

This fixed the problem for me. Since it is solved I cannot test the answer.

up vote 30 down vote accepted

Locate the partition in which linux is present with the help of following technique

grub rescue > ls
(hd0) (hd0, msdos9)
grub rescue > ls (hd0,msdos9)/
grub rescue > ls (hd0,msdos8)/
grub rescue > ls (hd0,msdos5)/ # suppose this is root and bootloader of linux
grub rescue > ls (hd0,msdos5)/
grub rescue > set root=(hd0,msdos5)
grub rescue > set prefix=(hd0,msdos5)/boot/grub
grub rescue > insmod normal
grub rescue > normal

Now, system's boot menu appears. Boot into linux.

sudo update-grub
sudo grub-install  /dev/sda # If the drive is hd0 the equivalent is sda, if it's hd1 then use sdb

This fixes boot loader.

  • 15
    I don't see what this should do. You specifiy a hell of a lot of commands, none of which makes any sense to me. Please add a little bit more explaining text! Why do you "count down" from msdos9 to 5? How do you see that "this is linux"?? In my case it shows (hd0,msdos1)! I cannot "count down" - and once I set root and prefix and do "insmod normal" I get exactly the same error message as before. Sorry. This is not an answer anybody could work with. :( – Zordid Aug 23 '14 at 11:50
  • 9
    As soon as I type insmod normal I get the message again: "error: attempt to read or write outside of partition." – user643722 Nov 11 '14 at 22:12
  • 2
    you say "suppose this is linux" without saying how I can tell which one linux is. Whenever I type insmod normal, I get back "error: unknown filesystem", this is not working for me. Also, can you explain why this happens in the first place? – msknapp Jan 4 '15 at 21:30
  • 1
    The best I've gotten is another grub prompt. The menu never pops up. – jbo5112 May 23 '15 at 23:45
  • 1
    I agree with @Zordid - just a list of cryptic commands without an explanation of what these commands do is not only not sufficient, it could be potentially dangerous. – Johsm Jul 5 '16 at 10:42

For anyone else that has this issue:

This was happening to me where a new install or grub repair would work and reboot, but the next time I rebooted, it would get this same "attempt to read error". Most times I would get a kernel panic and the computer would need a hard restart.

I followed some advice and did a new install using the advanced options (don't use the "erase disk and install ubuntu") using these partition settings:

  1. Create a 1 GB (1024 MB) ext4 partition on the beginning of the disk; mounted in "/boot"
  2. Create your desired install space in ext4 mounted in "/" MINUS your swap area
  3. Use remaining space for swap. (ALL partitions will be primary)
  4. In the boot install dropdown menu, select your "/boot" partition. Not the defaulted drive root!
  • This worked for me when the commands in the accepted answer were getting "Filesystem is unrecognised". I ended up using the same set of file systems, but this small dedicated /boot partition was what fixed my problem. Thanks. – GregHNZ Feb 4 '15 at 1:53
  • It seems this also works if /boot is the only primary partition. – Aaron Mason Jun 15 '16 at 6:59
  • Joined this site just to say that this also worked for me. The small boot partition was what I needed to get this to work when placing Ubuntu on an external HDD. Thanks! – rayryeng Jul 27 '16 at 1:25
  • It helped me: I had a big(>5TB) / partition, adding small /boot partition fixed the issue – neutrinus Oct 4 '16 at 15:26
  • Can one do this without deleting the existing partition? I have a large partition with all of my data starting at the beginning of the disk. – pir May 21 '17 at 23:24

I solved this problem by moving my Linux partition close to begining of hard disk. When linux partition was at the end of my 120 Gb HDD (40 Gb from end) I got this problem. No one solution didn't work. After moving linux partition to space from 40Gb to 80Gb problem disappeared.

  • How does one move the Linux partition to the beginning of the disk? – pir May 21 '17 at 23:23

After searching lots of hours I tried this solution and it works well, to reinstall the kernel:

sudo dpkg --configure -a
sudo apt-get install --reinstall linux-image-$(uname -r)

It can be easily solved through the Grub rescue prompt. The first answer isn't quite complete and I got the same error at first. Here is how it works:

1st we need to find the primary partition. This will be where the essential files needed for linux to boot will reside, so we enter this -

Grub> ls

You should now see a list comparable to (hd0) (hd0,msdos5) (hd0,msdos1). Note that you may have different partitions than myself, as well as multiple drives, but the process is the same.

Now search the partitions to find the primary -

Grub> ls (hd0)
Grub> ls (hd0,msdos5)
Grub> ls (hd0,msdos1)

Until grub outputs either a list of files on that partition or shows the filesystem type and date of last modification.

2nd we need to set up a few things once we've found our primary partition -

Grub> set prefix=(hd0,msdos1)/boot/grub
Grub> set root=(hd0,msdos1)
Grub> set

Once the last set command is executed Grub will output a list of different parameters. Now lets check that we've set the correct root and prefix -

Grub> ls /boot

Grub should output a list of files contained within /boot.

3rd we need to set the mount point and load the kernel -

Grub> linux /vmlinuz root=/dev/sda1
Grub> initrd /initrd.img

And lastly we boot the system -

Grub> boot

If you end up booting into the busybox shell, simply enter fsck /dev/sda1. After that just enter exit and your system will boot normally.

I am achieving this issue when I has used vmdk disk from OVA virtual machine package in virt-manager/QEMU/KVM. The virtual machine was failing with this error message.

Solution was to convert vmdk into qcow2:

qemu-img convert -O qcow2 MyAppliance-disk1.vmdk MyAppliance.qcow2

And to use converted image in virt-manager instead.

protected by Community Dec 23 '14 at 6:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.