1

I'm new to Ubuntu, running 13.10 on an Alienware M14x R2. The laptop comes with a "Intel Panther Point PCH - High Definition Audio Controller" sound card (for which I couldn't find a Linux driver). Running cat /proc/asound/card0/codec* | grep Codec returns "Creative CA0132," which I think is recognized as "Soundblaster Recon3di" in Windows. When I plug in my headphones, no audio device is detected, and sound continues to be played from the speakers. I've tried running alsamixer to disable auto-mute, but there is no auto-mute option. I've also tried appending "snd-hda-intel position_fix=1" with varying syntax to the alsa-base.conf file. I tried playing around with the model parameter, but none of the options listed here that seemed compatible worked (i.e. "alienware", "laptop", dell-eq"). At this point, I've wiped everything with a clean install to rule out any other newbie mistakes I might've made. Any advice would be appreciated.

Unfortunately I don't have the reputation points to post an image. Here's a screenshot of alsamixer.

pulseaudio --check returns no output.

pulseaudio --dump-conf, headphones in:

    ### Read from configuration file: /etc/pulse/daemon.conf ###
    daemonize = no
    fail = yes
    high-priority = yes
    nice-level = -11
    realtime-scheduling = yes
    realtime-priority = 5
    allow-module-loading = yes
    allow-exit = yes
    use-pid-file = yes
    system-instance = no
    local-server-type = user
    cpu-limit = no
    enable-shm = yes
    flat-volumes = no
    lock-memory = no
    exit-idle-time = 20
    scache-idle-time = 20
    dl-search-path = /usr/lib/pulse-4.0/modules
    default-script-file = /etc/pulse/default.pa
    load-default-script-file = yes
    log-target = auto
    log-level = notice
    resample-method = speex-float-1
    enable-remixing = yes
    enable-lfe-remixing = no
    default-sample-format = s16le
    default-sample-rate = 44100
    alternate-sample-rate = 48000
    default-sample-channels = 2
    default-channel-map = front-left,front-right
    default-fragments = 8
    default-fragment-size-msec = 10
    enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    deferred-volume-extra-delay-usec = 0
    shm-size-bytes = 0
    log-meta = no
    log-time = no
    log-backtrace = 0
    rlimit-fsize = -1
    rlimit-data = -1
    rlimit-stack = -1
    rlimit-core = -1
    rlimit-rss = -1
    rlimit-as = -1
    rlimit-nproc = -1
    rlimit-nofile = 256
    rlimit-memlock = -1
    rlimit-locks = -1
    rlimit-sigpending = -1
    rlimit-msgqueue = -1
    rlimit-nice = 31
    rlimit-rtprio = 9
    rlimit-rttime = 1000000

There was no difference with the headphones unplugged. amixer -c 0, headphones plugged in.

    Simple mixer control 'Master',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 99
      Mono:
      Front Left: Playback 99 [100%] [9.00dB] [on]
      Front Right: Playback 99 [100%] [9.00dB] [on]
    Simple mixer control 'PCM',0
      Capabilities: pvolume
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 255
      Mono:
      Front Left: Playback 255 [100%] [0.00dB]
      Front Right: Playback 255 [100%] [0.00dB]
    Simple mixer control 'Surround',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Mic SVM',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [on]
    Simple mixer control 'Mic1-Boost (30dB)',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [off]
    Simple mixer control 'IEC958',0
      Capabilities: pswitch pswitch-joined cswitch cswitch-joined
      Playback channels: Mono
      Capture channels: Mono
      Mono: Playback [on] Capture [off]
    Simple mixer control 'IEC958 Default PCM',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [off]
    Simple mixer control 'IEC958',16
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 99
      Front Left: Capture 99 [100%] [9.00dB] [on]
      Front Right: Capture 99 [100%] [9.00dB] [on]
    Simple mixer control 'AMic1/DMic',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [off]
    Simple mixer control 'AMic1/DMic Auto Detect',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [off]
    Simple mixer control 'Analog-Mic2',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 99
      Front Left: Capture 90 [91%] [0.00dB] [on]
      Front Right: Capture 90 [91%] [0.00dB] [on]
    Simple mixer control 'CrystalVoice',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [off]
    Simple mixer control 'Crystalizer',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Dialog Plus',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Echo Cancellation',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [off]
    Simple mixer control 'Equalizer',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'HP/Speaker',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [off]
    Simple mixer control 'HP/Speaker Auto Detect',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [off]
    Simple mixer control 'Noise Reduction',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [on]
    Simple mixer control 'PlayEnhancement',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Smart Volume',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]
    Simple mixer control 'Voice Focus',0
      Capabilities: cswitch cswitch-joined
      Capture channels: Mono
      Mono: Capture [on]
    Simple mixer control 'VoiceFX',0
      Capabilities: cenum
      Items: 'Neutral' 'Female2Male' 'Male2Female' 'ScrappyKid' 'Elderly' 'Orc' 'Elf' 'Dwarf' 'AlienBrute' 'Robot' 'Marine' 'Emo' 'DeepVoice' 'Munchkin'
      Item0: 'Neutral'
    Simple mixer control 'What U Hear',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 99
      Front Left: Capture 90 [91%] [0.00dB] [on]
      Front Right: Capture 90 [91%] [0.00dB] [on]
    Simple mixer control 'X-Bass',0
      Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [on]

The output was identical with the headphones out. Here's pacmd dump-volumes with the headphones in:

    Welcome to PulseAudio! Use "help" for usage information.
    >>> Sink 0: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
    Sink 1: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
    Source 0: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
    Source 1: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
    Source 2: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no

The output with headphones out was identical. Here's pactl info with the headphones in:

    Server String: unix:/run/user/1000/pulse/native
    Library Protocol Version: 28
    Server Protocol Version: 28
    Is Local: yes
    Client Index: 20
    Tile Size: 65472
    User Name: zach
    Host Name: zach-M14xR2
    Server Name: pulseaudio
    Server Version: 4.0
    Default Sample Specification: s16le 2ch 44100Hz
    Default Channel Map: front-left,front-right
    Default Sink: alsa_output.pci-0000_00_1b.0.iec958-stereo
    Default Source: alsa_input.pci-0000_00_1b.0.iec958-stereo
    Cookie: c0e8:4e43

There was a difference here. When I ran the command without headphones it, the output read Client Index: 22 on line 5.

Thanks for the feedback so far. AFAIK, there is nothing wrong with my headphones; I've used them on other devices.

edit: The headphones are detected when plugged into the headset jack. Sound settings will read "headphones" rather than "speakers," and the headphones will momentarily crack when plugged in, but the speakers will continue to play over them.

  • Screenshot of alsamixer please :) Headphones plugged in, preferably. – Seth Dec 29 '13 at 22:53
  • maybe your headphones input in computer is broken, or headphones themselves, check the cable as well – Xylo Dec 29 '13 at 22:54
  • Could you edit your question and provide more details? Like the Sound Card you are using? The output of pulseaudio --check, pulseaudio --dump-conf, amixer -c 0, pacmd dump-volumes and pactl info will be helpful, with both the headphones plugged and unplugged. – Braiam Dec 29 '13 at 22:57
  • Added the requested info, thanks for the feedback thus far. – Zach Dec 30 '13 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.