1

I've noticed that whenever I open a terminal the cursor blinks about 10 times and then freezes.

Is there a particular reason for this? What can the idea be?

2

This is not a bug, but a feature to save energy. Refer to this bug report on launchpad:

You can even stop the cursor blinking, refer to this question to see how:

  • your answer hits the spot!! thanks :D ...saving energy is least to expect – Mina Michael Dec 29 '13 at 14:44
0

The previously provided answer to this question does not work in Xubuntu 18.04, where the cursor blinking timeout for GTK applications is apparently controlled by xfconf rather than dconf.

If you're a Xubuntu user, you can do the following to make the cursor keep blinking in GTK-based applications (which includes gnome-terminal, xfce4-terminal, gedit, pidgin and many others):

  1. Open Settings Editor from the Settings menu.
  2. Select the xsettings "channel" on the left side of the interface.
  3. Click New.
  4. The name of the property needs to be /Gtk/CursorBlinkTimeout
  5. Set it to be an integer property.
  6. Specify a large number (but less than 2 billion).
  7. Click Save
  • Thank you for the answer but the question was simply "why". – Mina Michael Oct 19 '18 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.