17

My USB Drive is not mounted automatically but it has detected through lsusb.

I also used dconf-Editor but it is not working. Every time I have to mount manually through Disk Utility.

7

A complete description for configuring auto-mount is given here:

https://help.ubuntu.com/community/Mount/USB

If this does not help, please insert your usb-stick and post the last lines of dmesg and syslog.

  • I don't know why the automount is no longer work even with org.gnome.desktop.media-handling.automount key set to true, but manually mounting by the utility Disks to mount it works. – Yu Shen Dec 29 '18 at 20:04
2

Have you recently not unmounted the drive correctly, either power failure or a crash while writing to or reading from the drive? This can cause errors with the drive and while once mounted it functions normally the superblock may have errors causing it to not mount correctly.

As Requist asked, check dmesg immediately after inserting you flash drive, you may see one of the last lines as "Volume was not properly unmounted. Some data may be corrupt. Please run fsck.".

Check the device label in gparted then run

sudo fsck /dev/xxx (swapping xxx for your device)

You may get some details back about an invalid Superblock.

Fixing this is dependent on the drive filesystem, is it ext4 or Fat32 etc?

Here's a page on repairing an ext4 superblock

If your drive is fat32 or other msdos type, then testdisk may help but be careful with this tool, with great power...

sudo apt-get install testdisk
sudo testdisk

here is a post on using testdisk to repair a fat32 superblock issue. It links to this post, read both before starting.

Hope it helps.

  • I was trying to figure out why a FAT32-formatted thumbdrive wasn't automounting in GNOME (the kernel was recognizing it just fine). When I set the label (I didn't look at it beforehand; I'm guessing that it was empty), it was immediately seen and mounted. Can you explain this behavior? I would assume that, if there wasn't a label, GNOME would just provide a placeholder in the UI. Do you have an opinion whether this was an underlying filesystem issue that was simply corrected by setting a label? – Dustin Oprea Dec 31 '16 at 17:36
  • It should still mount the drive and give it a default 'disk1' type label if none are present. This should be in /media/[username]/disk1 etc. Check your automount config with dconf-editor, check org.gnome.desktop.media-handling for specific configurations on automounting and Nautilus actions. More here help.ubuntu.com/community/Mount/USB – Jools Jan 5 '17 at 11:02
  • For my situation, dmesg did not show any error message of mount failure, it seemed that there is no event of mounting. There is a piece of message: "sd 0:0:0:0: [sdb] Spinning up disk..." then after that there were message indicating spinning ready. The last message is "[sdb] Attached SCSI disk", then the USB drive is not automounted. But with Disk, I was able to mount it. – Yu Shen Jan 12 '19 at 15:31
  • For my above situation, maybe, there was some error message as they were in red color in dmesg: "[ 5925.011521] sd 0:0:0:0: [sdb] No Caching mode page found [ 5925.011530] sd 0:0:0:0: [sdb] Assuming drive cache: write through" after spinning ready. Before that there were also red messages: "[ 5920.917889] ses 0:0:0:1: Wrong diagnostic page; asked for 1 got 8 [ 5920.917899] ses 0:0:0:1: Failed to get diagnostic page 0x1 [ 5920.917906] ses 0:0:0:1: Failed to bind enclosure -19" after Spinning up disk... – Yu Shen Jan 12 '19 at 15:46
1

When all else fails, just mount it manually. Another alternative is upgrade to a recent version of Ubuntu. Both have worked for me in the past.

$ mkdir xxxxxxx
$ sudo mount /dev/sdb1  xxxxxxx
$ sudo umount xxxxxxx

or

$ pmount /dev/sdb1  xxxxxxx
$ pumount xxxxxxx
  • The question isn't asking how to manually mount a partition: askubuntu.com/questions/1029040/… – WinEunuuchs2Unix Jul 19 '19 at 16:17
  • "when all else fails" – JohnMudd Jul 19 '19 at 20:20
  • 1
    Someone else could say "use Windows" I guess. Anyways just trying to point out why someone else down voted your answer. – WinEunuuchs2Unix Jul 19 '19 at 21:59
  • 1
    I agree with the When all else fails., so an edit and an upvote. ;-) – Fabby Jul 21 '19 at 7:41
0

This is a bug described in Bug #1768010: usbmount does not work on Bionic. The solution, also given in Unix & Linux Stack Exchange, is the following:

Edit the systemd-udevd configutation

sudo systemctl edit systemd-udevd

insert the following two lines:

[Service]
MountFlags=shared

then run:

sudo systemctl daemon-reload
sudo service systemd-udevd --full-restart

Note also that this workaround is not perfect: a delay of 40 seconds can be observed between the time an usb key is inserted an the time the auto-mount is fully executed.

  • It did not work for my Ubuntu 18.04 to solve the problem of no automount for USB drive. – Yu Shen Jan 12 '19 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.