12

Every time I launch dota 2 on my pc running 13.10 it looks like this: enter image description here

The side and top bars don't go away even though the game is in full-screen. I only have this problem with dota 2 all other games work fine in full-screen. I have tried going into the settings and enabling the shortcut that forces fullscreen mode but nothing happens when I press the shortcut. is there a way to fix this or force ubuntu into fullscreen mode?

This problem is only with Dota 2 and not other fullscreen apps/games.

  • It's more likely to be a problem with the game's settings, not Ubuntu. Have you fiddled about with the desktop and windows settings in Dota itself? – comrademike Dec 29 '13 at 10:04
  • @comrademike dota 2 doesnt seem to have any settings apart from steams launch settings. I have tryed setting the launch settings to "-w 1680 -h 1040"(my screen res) but this had no effect – Qwertie Dec 29 '13 at 10:08
  • is there a terminal command to make ubuntu fullscreen? – Qwertie Dec 29 '13 at 10:19
  • is with any application that has Fullscreen mode or only steam games? – Braiam Dec 29 '13 at 12:26
  • Have you looked in the dota directory to see if there is a config file where you can set screen sizes? – comrademike Dec 29 '13 at 12:27
19

I managed to go to the settings in the game and changed the window setting from boarder less to full-screen. Dota 2 now works full screen.

  • 1
    Yes that worked, I couldn't see that before because the launcher was covering the settings button – Qwertie Jan 29 '14 at 5:10
  • Ok, glad it worked ok. I see what happened with the unity launcher getting in the way. – Enjoy87 Jan 30 '14 at 10:57
4

Change Borderless Window to Fullscreen in Dota 2 settings (Video).

1

I personally did not like having to go to full screen, I like being able to interact with my other monitor without losing focus on my game. I also wanted my launcher to be on the monitor to my left but have the game on my monitor to the right (which full screen doesn't allow you to do.)

The only draw back so far is that I cannot get the window to draw over Unity's menubar at the top so you end up sacrificing 20px in height.

The solution for me was to set the following launch options in steam.

  1. Right Click Dota2 in your steam library
  2. Click Set Launch Options
  3. Add the following -h 1180 -w 1920 -x 1280 -y 0 -noborder
    • -w should be the width of the monitor you want it on
    • -h should be height of the window, I couldn't get rid of the menubar so I subtracted it's height (20px for me) from the height of the game.
    • -x should be the offset of your second monitor (my second monitor is 1280px wide
    • -y is the offset from the top, since the menu bar isn't taken into account I set this to 0, it may not even be required to include
    • -noborder should indicate to dota that the game should be launched as a bordless window but it didn't so I had to do steps 7 through 10. This option may not be useful
  4. Click OK
  5. Click Close
  6. Launch Dota2
  7. Click the Settings Cog
  8. Click Video Options
  9. Set Display Mode to Borderless Window
  10. Click apply (you may need to restart the game here)

If you're on a one monitor setup or you want the game to be in the same monitor as your launcher the same principles apply just adjust the -w and -y options to accomodate, however, you'll also be sacraficing your width as well as your height.

For now I think this is the best you can do.

That said the new reborn client has an additional option in the Video settings to allow your fullscreen game to not minimize when it loses focus. I haven't played with it much but it does mean that your launcher won't be accessible (as far as I could tell in my limited testing) as the game will still launch on the dominant monitor that has launcher assigned to it.

1

In steam, right click Dota 2, go to properties -> set launch options. In the texbox type "-fullscreen" (without the quotes). Restart Dota 2.

0

The other solutions did not work for me, so for others who might have this problem, here's what I did.

In CompizConfig Settings Manager, choose Utility > Workarounds and disable Legacy Fullscreen Support.

Then restart your computer.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.