0

I have just recently installed Ubuntu 13.10 and decided to install the necessary Nvidia driver:

sudo apt-get install nvidia-current

Then I reboot and find to have the black screen. I went into the terminal with Control-Alt-F1 and executed the following and rebooted:

sudo apt-get remove nvidia-current

But I still get the black screen. How can i fix this?

2
  • try sudo apt-get purge nvidia-current Dec 29, 2013 at 9:42
  • Ok, I tried doing that and I still get the black screen. When I went and logged into the terminal, I also tried startx but that didn't work too
    – Tihomir
    Dec 29, 2013 at 9:49

3 Answers 3

1

Try these commands on virtual console(ctrl+alt+F1),

sudo rm /etc/X11/xorg.conf
sudo apt-get purge nvidia*
sudo service lightdm restart
3
  • Apparently there is no such file or directory as /etc/X11/xorg.conf
    – Tihomir
    Dec 29, 2013 at 10:03
  • But I tried the second command but it is still a black screen and startx doesn't work either
    – Tihomir
    Dec 29, 2013 at 10:03
  • try sudo apt-get purge nvidia* in virtual console. Dec 29, 2013 at 10:07
1

If you installed the Nvidia Proprietary drivers and you get a black screen, you probably need to set nomodeset. So try to install the driver again and then do the following to get around the black screen.

To do this you need to:

  1. Hold down Shift while booting, until you get to the Grub boot menu.
  2. Select your boot option and press e to edit it.
  3. Edit the line that has "quiet splash" in it to "quiet splash nomodeset"
  4. Try booting that by pressing F10.
  5. If it works, make it permenant by editing /etc/default/grub to display the same in that particular line. Remember to do a sudo update-grub afterwards.
1
  • I tried the method that you have stated and only to find out that it doesn't work for me. I am going to have to find another way to install the Nvidia Drivers
    – Tihomir
    Dec 29, 2013 at 12:58
0

This site always works for me: http://news.softpedia.com/news/How-to-Install-the-Latest-NVIDIA-331-20-Drivers-in-Ubuntu-13-10-399182.shtml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.