Okay, I just updated Ubuntu to 11.04 and my wired internet connection is down. The old setup used a static IP, but I'm not even interested in maintaining that. I just want wired internet access. Here's the extent of my troubles as cataloged thus far:

  • No Wired Internet (wireless works fine)
  • No Networking icon w/out running nm-applet from terminal (it goes away again when I close the terminal
  • When I DO run nm-applet and click on the networking icon at the top of the screen "wired network" is greyed out, and right below that it says "device not managed".

Problem solved. I edited /etc/network/interfaces which looked like this:

auto lo
iface lo inet loopback

 auto eth0
 iface eth0 inet dhcp

to look like this:

auto lo
iface lo inet loopback

 auto eth0
 iface eth0 inet static

I'm not sure how it should have been correctly setup for dhcp, but what I have now seems to work fine, so I'll stick w/ that.

  • select your answer as the accepted one.I was going to advise you to do the same! :) – Ubuntuser May 3 '11 at 16:48

Go to your terminal and use

sudo pppoeconf

to configure your wired internet connection.


Go to /etc/NetworkManager/NetworkManager.conf and changed managed=false to true and then do sudo service network-manager restart


make sure your account is an Administrator. By default the account you create when installing the OS is given "custom" permissions, which does not grant you the ability to change the system's settings. You do not have to log in as root to elevate your permissions.

  • What do you mean when you say that the account you create when installing can't change the system's settings. The account created when installing Ubuntu most certainly is (and always has been) an administrator account. The group memberships may be "custom" but this user is a member of the admin and/or sudo groups (depending on which Ubuntu release you're using), and that's what matters. Furthermore, a non-administrator cannot make him/herself an administrator; it would be necessary to use single user mode (such as recovery mode) or a live CD to fix this. – Eliah Kagan Aug 24 '12 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.