I've just picked up a UP2414Q and I've connected it via displayport 1.2 which runs 60hz. The issue is that it ends up showing X two screens, well kind of, so that I end up with it acting as if I've got two monitors within my one 24" frame.

I've gone through the nvidia settings and cannot find a way to get them to join up as a single wide display. I've found hints at doing things like

OPTION "TwinViewXineramaInfoOverride" "3840x2160+0+0"


Option "NoTwinViewXineramaInfo" "1"

Neither of which worked. I wonder if I'm missing another part to the puzzle. Any hints on how to correct up my config would be appreciated. I'm currently running a new daily build of trusty in the hopes that more recent X and nvidia drivers would help things out.

I've pasted below my current X config and linked to the X log below.

Here is a screenshot of the current dual display setup. Notice the window manager is acting as if there are two different monitors.


Logfile: http://paste.ubuntu.com/6654719/

xrandr output: http://paste.ubuntu.com/6669699/

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@batsu)  Mon Dec  9 17:08:08 UTC 2013

xdpyinfo -ext XINERAMA | tail -2

head #0: 1920x2160 @ 0,0
head #1: 1920x2160 @ 1920,0


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL UP2414Q"
    HorizSync       31.0 - 140.0
    VertRefresh     29.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 660 Ti"

Section "Screen"

# Removed Option "metamodes" "DP-1.8: 1920x2160_60 +1920+0, DP-1.9: 1920x2160_60 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4.8"
    Option         "metamodes" "DP-1.8: nvidia-auto-select +1920+0, DP-1.9: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24


  • What do you mean by "4k monitor"?
    – Braiam
    Dec 28, 2013 at 20:36
  • 1
    @Braiam en.wikipedia.org/wiki/4K_resolution
    – hatch
    Dec 28, 2013 at 22:53
  • Do the card supports this resolution? And the driver? Tried to disable "nvidiaXineramaInfoOrder" "DFP-4.8"? and if I read the log correctly, the monitor is detected as two monitors, was this working on other OS's?
    – Braiam
    Dec 30, 2013 at 23:28
  • Braiam, yes, the card supports the resolution, if I run it in dp 1.1 I can run the resolution at 30hz as one display. It's the 1.2 MST business I think that I need to config around. I've not tested it in any other OS's. I'm a single OS kind of guy. :) The driver is 331 and I believe it does/should support it. Others seem to have set things up like this with multiple monitors. 4k monitors are new enough that I've not found a ton of examples to go through.
    – Rick
    Dec 31, 2013 at 2:13
  • 1
    @Rick, you need to put that info in the question, not a comment so it's not buried! Dec 31, 2013 at 4:51

4 Answers 4


I'm working on the same issue with a Panasonic TC-L65WT600, and while I haven't found a perfect solution, I came across this workaround that did somewhat work for me.

Add the line

Option "Xinerama" "1"

to your xorg.conf Section "ServerLayout".

This is counterintuitive, because in effect this breaks both Xinerama and RandR. The NVIDIA driver has its own implementation of Xinerama and RandR, and by enabling the regular Xinerama extension, it conflicts with NVIDIA's implementation, the effect being both are disabled.

I haven't tested this thoroughly to see if it breaks anything else, but it's worth a try as a temporary workaround...

  • This worked I guess. You're right, it seems hacky, but sure enough I've got the ability to tile across the center of my monitor now. Thanks for the tip.
    – Rick
    Jan 3, 2014 at 4:28
  • I didn't have a /etc/X11/xorg.conf but using the one above with this modification worked for me. Ubuntu control centre complains about the lack of RandR extension but everything else seems to work.
    – shuckc
    May 10, 2014 at 10:54
  • So I guess you followed the user guide of the monitor on how to allow the 4K resolution. link Page 45-46:

    Setting Up the DP1.2 Display

    The default out of factory setting in the UP2414Q is DP1.1a. To enable 3840 x 2160 at 60 Hz, ensure the graphics card of the DP source is DP1.2 certified with MST feature, capable of supporting resolution up to 3840 x 2160 at 60 Hz, and its driver supports DisplayID v1.3, then change the DP setting to DP1.2 by performing the below steps: ...

    Read the rest in the manual

  • I looked up your GPU here. It says it supports DP1.2 MST. (If I got it right) So that shouldn't be either a problem.

  • I had no clue how this 4K works, so I looked for some more info for this topic. So it looks like it is the normal way for the monitor to show up as two displays, and you only have to enable horizontal spanning for the nvidia card. (To make the two displays a big virtual display.)

  • I looked up the nvidia driver's readme, chapter 12. Based on the info given there, and these lines in your Xorg.log:

    [   259.448] (II) NVIDIA(0): Virtual screen size determined to be 3840 x 2160
    [   263.248] (II) NVIDIA(0): Setting mode "DP-1.8:nvidia-auto-select+1920+0,DP-1.9:nvidia-auto-select+0+0" 

    I think that your driver is properly set up to mimic a joint virtual screen to the X-server.

  • Later in the log come these lines:

    [   264.017] (II) NVIDIA(0): Setting mode "DP-1.8: nvidia-auto-select @1920x2160 +1920+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}, DP-1.9: nvidia-auto-select @1920x2160 +1920+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}"
    [   264.055] (II) NVIDIA(0): Setting mode "DP-1.8: nvidia-auto-select @1920x2160 +0+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}, DP-1.9: nvidia-auto-select @1920x2160 +1920+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}"
    [   272.635] (II) XKB: reuse xkmfile /var/lib/xkb/server-75DD9E258FEFC19A572284D7C4A5BC6BFE771BAD.xkm
    [   336.272] (II) NVIDIA(0): Setting mode "DPY-6:nvidia-auto-select+1920+0,DPY-7:nvidia-auto-select+0+0"

    The first line sets a mode which is not the mode you want, because that will mirror the two screens because of the +1920+0 offset for both. (If I got these things right) But the next line immediately resets the mode to a correct one. And the last line of these, which comes a minute later than the others, I don't know what is that, from where the DPY-x screens got here.

    My only guess is that when the nvidia driver reports the correct virtual screen size it says:

    [   259.448] (II) NVIDIA(0):     "DP-1.8:nvidia-auto-select+1920+0,DP-1.9:nvidia-auto-select+0+0"

    whereas it the end (or at almost the end) the line reads:

    [   264.055] (II) NVIDIA(0): Setting mode "DP-1.8: nvidia-auto-select @1920x2160 +0+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}, DP-1.9: nvidia-auto-select @1920x2160 +1920+0 {ViewPortIn=1920x2160, ViewPortOut=1920x2160+0+0}"

    And that means that the offset is the opposite in these two lines. So in the former the DP-1.9 display is the first and the DP-1.8 is the second, but in the latter the order changes. Because you didn't provide a picture of the screen I can't know that your problem is that if you go out with the cursor on the right it comes back on the left. But I may try to set the metamode to the former one. So change this line:

       Option         "metamodes" "DP-1.8: nvidia-auto-select +1920+0, DP-1.9: nvidia-auto-select +0+0"

    to this one

       Option         "metamodes" "DP-1.8: nvidia-auto-select +0+0, DP-1.9: nvidia-auto-select +1920+0"

    Or try the MetaModeOrientation option with something like:

       Option "MetaModeOrientation" "DP-1.8 RightOf DP-1.9"

So this was my 2 cents into this problem. I hope it is not totally useless in your case.

  • Thanks, your logic follows my own. I've enabled DP 1.2 in the monitor configuration and the nvidia-settings is reporting each 'display' as being at 60hz. I've added a screenshot link in the my question above. Changing the metamodes actually seemed to have little effect. I've gotten the two screens setup to work as a decent dual monitor situation, but nothing seems to get me a single display workspace 3840 wide.
    – Rick
    Dec 31, 2013 at 18:13

I had the same issue, and almost found a fix.

Assume you are starting with SST, ie. DisplayPort 1.2 off in the monitor's OSD menu. xrandr -q shows you are in 30Hz mode, and you can't force it to 60Hz since SST does not support it.

Switch DP 1.2 to on in OSD. The screen is now in MST, but randr isn't - and you still can't force 60Hz. In terminal write xrandr --output DP-1 --off (replace DP-1 with the appropriate id). Screen will turn off briefly, and come back on. Now you are in MST, and checking xrandr -q will confirm you have 60Hz!

The issue is that you have a duplicate background, menu bar on only on half the screen instead of spanning the whole screen, Youtube and video overlay only maximize to half the screen.

This is apparently a shortcoming of randr. The above tips are from Aaron Plattner from nVidia, in response to my query on how to enable MST at 60Hz for 4K monitors in Linux.

The issue is not resolved, and he has contacted the randr community to find a solution. So if anyone in the know is reading this, please check the thread above for further information so we can get the ball rolling!

  • 1
    Unfortunately there is no full fix to the issue. You can set MST on with xrandr, but there are some anomalies left which make the screen largely unusable. I've updated the OP with full instructions. I don't know much about xrandr, so can't help any further. Hopefully someone who's reading this can, and will contact Aaron Plattner from nVidia and/or the randr team!
    – bramford
    Feb 4, 2014 at 17:30
  • never mind. Just note you can delete non important comments to keep page clean.
    – user.dz
    Feb 4, 2014 at 22:07

Ok, I used to do this with dual head video cards with VGA and DVI ports. I think it might work with DP1 ports. I think xrandr would be the tool to use. http://www.thinkwiki.org/wiki/Xorg_RandR_1.2

  1. Run a query to see what's connected.

    xrandr -q
  2. Try a test resolution:

    xrandr --output DP1 --mode 3840x2160
  3. Create a ModeLine. This is important to get correct refresh rate and avoid prematurely burning out the monitor. Use cvt: http: slashslash linux.die.net/man/1/cvt

    cvt 3840 2160 30
  4. Add this ModeLine to xorg.

  5. Read this page to set xrandr changes persistently:

  6. You may need to edit xorg to add a SubSection called virtual.

  • I've pasted a link to my xrandr config. The displays show up as dp-1.8 and dp-1.9. I can't set a single resolution on the display port that I can tell. I think the issue is more at the X/nvidia level in order to get it to show to xrandr as a single port or screen. I attempted to set the modeline in the DISPLAY subsection of the screen config without effect.
    – Rick
    Dec 31, 2013 at 18:18
  • Just some comments that may or may not help. An xorg file generated by the nvidia driver may be the root of the problem. It may be difficult to configure properly. It has caused problems for me in the past. Debian recommends using the X tool that comes with the OS. Sorry, I don't know how to fix that. I always just reinstalled and started over. That said I would try a few things first. I never used Xinerama. I used "TwinView" instead. Here's what I would do with your xorg. This is the way I used to do it. See next comment Jan 1, 2014 at 3:57
  • Comment out these entries: The Xinerama option in Section "ServerLayout". The Stereo, Xinerama and metamodes option in Section "Screen" Move the DPMS option from monitor section to the device section. Add these entries to the device section Option "MetaModes" "1920x21600, 1920x2160" Option "TwinView" Add these entries to the display subsection. Modes "1920x2160" Virtual 3840 2160 I run two 1600x1200 monitors plugged into a dual head card. The Virtual resolution in the display subsection is what tricks the X server into thinking I have one screen at 3200x1200. Here's an example xorg. next Jan 1, 2014 at 3:58
  • My sample xorg file.paste.ubuntu.com/6671569 Jan 1, 2014 at 4:01
  • I'm currently running Debian Squeeze with dual monitors. A 1920x1200 and 1600x1200 for a single display of 3520x1200. I don't recall installing the nvidia driver but I'm sure I must have then I just used monitor preferences in the Debian menu to set it. There's no xorg conf file for me to edit. So I've forgotten how to do it. They made it easy for me, lol. Jan 1, 2014 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.