Initially my PHP was running well and after that when I installed perl CGI modules in order to run my CGI programs, there was problem.

From the local host, I am not able to compile my PhP files nor my CGI files, I have tried all sort of possible solutions available in the google and finally wriring here.

I have tried to restart the apache2 and here is the syntax error I could find.

Syntax error on line 151 of /etc/apache2/apache2.conf:
Invalid command '/etc/phpmyadmin/apache.conf', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.

Kindly give me a possible solution to run both my CGI and PHP scripts.?

1 Answer 1


Ensure that you're including the right file: etc/phpmyadmin/apache.conf

If you used apt-get install phpmyadmin, you don't need to reference the apache.conf file, it is automatically configured.

Take a look at this post too: https://www.digitalocean.com/community/articles/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu

  • I have tried the same in the given link...But it still gives the same error when i restart the apache
    – Bio_Ram
    Dec 30, 2013 at 10:16
  • try using include /etc/phpmyadmin/apache.conf. confirm that the file exists in the location specified Dec 31, 2013 at 15:37
  • My PhP scripts were working well but still i am facing problem in executing the CGI scripts. In /usr/local/apache2/conf/httpd.conf, the configuration was ServerRoot "/usr/local/apache2" ScriptAlias /cgi-bin/ "/usr/local/apache2/cgi-bin/" and removed "#" from AddHandler cgi-script .cgi in order to enable the execution of CGI program from anywhere
    – Bio_Ram
    Jan 1, 2014 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.