I've installed the 11.04 64bit version and now i can't install Draftsight (32bit with force architecture option) because there is an error with the library libexpat1.. anyone know how solve?

andrea@andrea-HP-Pavilion-dv5-Notebook-PC:~$ sudo dpkg --force-architecture -i DraftSight.deb 
[sudo] password for andrea: 
dpkg: warning: the following problems are ignored via the --force option:
 the architecture of the package (i386) does not match system (amd64)
dpkg: problems with pre-dependencies DraftSight.deb containing dassault-systemes-draftsight:i386:
 dassault-systemes-draftsight:i386 depends on libexpat1 (>= 2.0.1-4)
dpkg: errore processing DraftSight.deb (--install):
 dependency problem - dassault-systemes-draftsight:i386 not installed
There were errors in processing:

Editor's note: the error messages have been translated and don't match the real ones exactly.

  • In ubuntu 12.04, consider modifying the control file of the deb package to remove dependence problem. The systems seems to keep track of the problem and de-installing the application, next time synaptic/dpkg is recalled. more info at linuxaideddesign.blogspot.it/2012/03/…
    – Giuliano69
    Jul 21, 2012 at 9:46

16 Answers 16


After you install all dependencies mentioned above (that is libdirectfb-extra, libxcb-render-util0, libaudio2) you should install Draftsight using the following command:

sudo dpkg -i --force-architecture,depends ./DraftSight.deb

Obviously you should run this command while inside the folder where you have saved Draftsight.deb.

Worked on Ubuntu 11.04 x64


From: OMG Ubuntu

Free AutoCAD clone ‘DraftSight’ hits Linux Beta

Download a pre-packaged .deb file for Ubuntu 9.10+ at the following link: download (66.8MB)

64bit Ubuntu users note: The DraftSight beta .deb provided is 32bit. To get DraftSight to run in Ubuntu 64bit will need to install the following missing library:

 sudo apt-get install libdirectfb-extra libxcb-render-util0

After this, install the .deb via a Terminal using the ‘force architecture’ command. Assuming you downloaded it to your Downloads folder:

sudo dpkg --force-architecture -i ~/Downloads/draftSight.deb

You probably did not install the missing library.

  • I had to install libcamberra0 to get it to run on 13.10. Oct 10, 2013 at 8:45

On 64bit Kubuntu 12.04 there is a libgtk-x11 error.

/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libgtk-x11-2.0.so.0: c

Solve with this:

sudo apt-get install libgtk2.0-0:i386

I'm transcribing what I found in this UbuntuForums post by player107. The procedure is the following:

  1. Unpack the DraftSight file in some directory (ex: DS).

  2. Copy the contents of DS/opt/ and DS/var/ to /opt and /var/opt.

  3. Go to DS/DEBIAN.

  4. Run:

    sudo ./preinst
    sudo ./postinst
  5. A menu should have been created in the graphical Ubuntu menu: you can launch it.

It is also mentioned that a problem with the screen may arise, but it didn't occur to my case. To avoid this, if you encounter this problem, run the following commands:

sudo apt-get install libdirectfb-extra
sudo apt-get install libxcb-render-util0

Installing on Ubuntu 11.10 64 bit can by skipping the dpkg-installer:



I found that it is possibly to run this software by running it as a root (sudo) but still not functional trough normal launcher. Ubuntu 11.04 start command is:

sudo /opt/dassault-systemes/draftsight/bin/DraftSight

or you don't have even to do that

just extract .deb file and run it as a root and it will work.

There is only a problem to run it as normal user


I have succeeded in to install draftSight in Ubuntu 12.04 (beta2) 64 bit. I just have installed the required libraries and then extracted the .deb file content.

I copied the extracted folder to /usr/local/ and then just change the owner:

sudo chown -R  user:group draftSight/

After that i just have created a launcher in the desktop..



I have tried forcing the architecture to install DraftSight, even after installing the packages mentioned in the previous posts, but I always get this error:

dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
dpkg: regarding DraftSight.deb containing dassault-systemes-draftsight:i386, pre-dependency problem:
 dassault-systemes-draftsight:i386 pre-depends on libexpat1 (>= 2.0.1-4)
  libexpat1:i386 is unpacked, but has never been configured.
dpkg: error processing DraftSight.deb (--install):
 pre-dependency problem - not installing dassault-systemes-draftsight:i386
Errors were encountered while processing:

I have tried installing this libexpat library through getlibs but nothing seems to let DraftSight install correctly.

Consequently, I tried the method copying the files manually (suggested by Juan José Alca Machaca), and DraftSight appears in the menu and I can run it, but it crashes when I do common operations, or run commands like DimensionStyle


Above solutions does not worked in fresh install of natty narwhale 11.04 64 bit.

System crashed after attempts: dpkg with force & make deb file for all architectures & trying alien rpm to deb & (re)installation and configuration libraries for i386 (supposed it destroyed system). I rescue system with reinstallation and configuration libraries for amd64 & update and upgrade system. Ubuntu 11.04 Natty and DraftSight works.

You can try install libc6 for i386 (simultaneously to already installed libc6 for amd64) from synaptic. I guess it helps in my case.


Don't forget to right click 'DraftSight.deb' then choose 'Properties'. Select the 'Permissions' tab, and click ' Allow Executing File as Program'. Then run:

sudo dpkg -i --force-architecture,depends ./DraftSight.deb

I finally got it to work under Ubuntu 11.04 64 bit.

First follow detailed instruction (one of above since pretty much any method will work). Don't forget to put all dependencies

Believe me or not after I installed it I had to delete configuration files in home directory which are starting with "." or move them to some folder if you have wine app or something like that.

For people which doesn't like this idea, to delete configuration files, try to create another user account and run it from there.

After that I found out that enabled **buttons have icons application will crach when i try for example to click on Open.**

and that's it for now. When I get more knowlegde i will postenter image description here


"I found that it is possibly to run this software by running it as a root (sudo) but still not functional trough normal launcher. Ubuntu 11.04 start command is:"

Jorge Castro: I faced the same problem after installing DraftSight. I solved it by running DEBIAN/preinst script 'as normal user', it then asks for administrator password, then the licence agreement gui shows up(accept it). Keep doing it until it says "access control disabled, clients can connect from any host" in the terminal, run postinst script after that.

You may want to delete any '.draftsight' dir in your home directory PRIOR to running the scripts in DEBIAN folder.

  • You may want to delete any '.draftsight' dir in your home directory PRIOR to running the scripts in DEBIAN folder.
    – kapz
    Dec 20, 2011 at 19:20

I had the same problem but solved finally. Here is the solution:

  1. Install the two missing dependencies:

    sudo apt-get install libxcb-render-util0
    sudo apt-get install libdirectfb-extra
  2. Move your DraftSight.deb file to your home folder /home/yourusernamehere.

  3. Then you have to force install the DraftSight package:

    sudo dpkg -i --force-architecture DraftSight.deb

It is working for me.



Source: http://steamcommunity.com/app/221410/discussions/0/846940248727134912/


sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install ia32-libs

You'll have to download files while updating. about 200MB, depends on your situation.

I'm using ubuntu 12.10.


This is for 14.04:

To install DraftSight on 14.04 (64 bits):

Step 1: Install i386 libraries

sudo apt-get install libuuid1:i386 libice6:i386 libsm6:i386 libxt6:i386 libaudio2:i386 libgtk2.0-0:i386 libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libglu1-mesa:i386

Step 2: Download DraftSight Installer :

download .deb from source

Step 3: Install DraftSight CAD

after changed to downloaded folder run

sudo dpkg -i draftSight.deb

On Ubuntu 11.10 64 bit there is still a dependency problem:

dassault-systemes-draftsight:i386 wymaga wstępnie libdirectfb-extra (>= 1.2.7-2)

BUT it works if you extract DraftSight.deb and then run:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .