Sometimes (randomly), the synaptics touchpad driver won't load on bootup. When reading /var/log/boot.log, i don't see anything touchpad-driver-like being started when this happens.

But the file /dev/input/mouse0 exists and I can perform simple actions with my mousepad (pointing, clicking, but no scrolling) and the pointer speed is very low when moving it via the touchpad.

When typing synclient into terminal while this is happening, it tells me Couldn't find synaptics properties. No synaptics driver loaded?

Whats the problem here?

  • Touchpad procession of Xorg is done by xserver-xorg-input-synaptics. So i doubt it will have an effect. – s3lph Dec 27 '13 at 17:55
  • Sorry, did you try reinstall it? – user224082 Dec 27 '13 at 18:04
  • Yes, both input-mouse ans input-synaptics. But I can only tell after a few days whether it worked. – s3lph Dec 27 '13 at 18:30
  • Try : sudo apt-get purge xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-synaptics . Purging is needed to remove malconfiguration. – user224082 Dec 27 '13 at 20:09
  • Going out on a limb here as it's one of those pesky "sometimes" errors. Have you tried moving the synaptics /usr/share/X11/xorg.conf.d/5?-synaptics*.conf to /etc/X11/xorg.conf as "the X Server treats the collection of configuration files as one big file with entries from xorg.conf at the end" (from the manual) and I'm suspecting a timing-based issue... (And no one has provided any suggestion in nearly a year nor provided this feed-back) – Fabby Nov 23 '14 at 17:30
up vote 2 down vote accepted

I started having this problem after upgrading from 12.04 to 14.04. Tried purging / reinstalling xserver-xorg-input-synaptics, but the problem persisted. I decided to browse the available packages in Synaptic Package Manager, and found this:

xserver-xorg-input-synaptics-lts-trusty

I installed it alongside the other ("generic") package. Hopefully this fixes the issue.

  • I fail to see how a "Hopefully" was accepted as the answer. SE is meant to form a knowledge base, but I came to this high search-ranked thread expecting info, and the accepted answer tells me nothing. Did that package solve this? for you or the OP? Still, since I have the same problem on Debian 8.2, installing a Ubuntu specific version is not an option for me (which, sorry, but makes this even less useful). – underscore_d Oct 19 '15 at 19:07

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.