5

When I click finish on a new project in Eclipse which I installed with this command sudo apt-get install eclipse-platform. This popup window comes and no matter if I choose Yes or No it closes the application:

enter image description here

I have tried running eclipse from terminal so I can see what happends, but I'm not so good to find out the problem, but this is what I get:

jeggy@jeggy-Dell-System-XPS-L502X:~$ eclipse
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f305f07a528, pid=11475, tid=139846321936128
#
# JRE version: 7.0_25-b30
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x19528]  g_object_get_qdata+0x18
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/jeggy/hs_err_pid11475.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   https://bugs.launchpad.net/ubuntu/+source/openjdk-7/
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

That font error is because I'm running Kubuntu, and I get that error right away but I don't think it has anything to do with it closes when I create a new project. And if anyone is interested I posted the pid11475.log here. And as it says there try "ulimit -c unlimited", I have tried that but didn't change anything.

7

I had the same issue as well on Kubuntu 14.10. I wasn't even able to change the theme under System Preferences -> Application Appearance because eclipse crashed as soon as I tried to click "Application Appearance".

But editing the gtkrc file under /usr/share/themes/oxygen-gtk/gtk-2.0/ as explained in https://stackoverflow.com/questions/26436009/eclipse-luna-crashes-on-new-project-in-ubuntu finally did the trick. Change this line:

 GtkComboBox::appears-as-list = 1

to:

 GtkComboBox::appears-as-list = 0
1

I had the same issue and it turned out to be due to oxygen-gtk theme. After choosing a different gtk theme (QtCurve neither work), I've seen no more crashes. On KDE, you can change these settings on System Preferences -> Application Appearance -> GTK . Changing GTK2 theme is enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.