I recently shifted to Ubuntu.

My beats audio speakers connected to my laptop are not working. I am using an hp ENVY dv6 laptop.

What should I do?

  • Try with installing sound driver packages sudo apt-get install linux-sound-base alsa-firmware-loaders alsa-oss alsa-source alsa-tools alsa-tools-gui alsa-utils alsamixergui alsaplayer-alsa alsaplayer-common alsaplayer-daemon alsaplayer-esd alsaplayer-gtk alsaplayer-jack alsaplayer-nas alsaplayer-oss alsaplayer-text alsaplayer-xosd libsox-fmt-alsa alsa-base. Reinstall the present ones.
    – user224082
    Dec 27, 2013 at 17:33
  • ^ this does not work
    – D M
    Mar 30, 2018 at 7:34

4 Answers 4


This was done in my own HP envy and this process works on all HP laptops containing beats audio.


Install hda-jack-retask from https://launchpad.net/~diwic/+archive/hda . Download this small application according to your version of Ubuntu. After the completion of download, install the app.


After the app is installed, go to the terminal and type hda-jack-retask which opens the file. Open app using terminal


At the top, in codec section, select IDT 92HD91BXX codec.

This code varies with various models. Check it STEP 4

Check the “ Show unconnected pins” at the right side. STEP 5

After this, you will see different types of unconnected pins of your sound driver. You have to map these pins to the right part of the beats audio drive. Care must be taken at this point.

You can see there are various types of pins. We are not aware about these things. Even I don’t know

what I am doing and is confusing. BUT do not worry at all.

You just have to play on three pins. They are 0x0d , 0x0f and 0×10.


Go to the section having pin id : 0x0d .

Change (Internal Speaker, Front side) to “Internal speaker”.


Go to the section having pin id: 0x0f.

Change (Not connected) to “Internal speaker”. This part is about the under-display speakers.


Go to the section having pin id: 0×10.

Change (Not connected) to “Internal speaker (LFE)”. This part is about the sub-woofer.


You are finally done with those pin settings. Apply it now. You can test with some sound. Check whether all the speakers are producing desired sound. The settings must be done as in following picture.

Do as it is


If everything is all right, install boot override from the bottom right side and restart your device.

Finally you must have sound with beats audio. Enjoy the sound and music. Also plug in the headphones, it must disable the external sound when the headphone is plugged in.

you can visit here for more information. http://www.chromeearth.com/enable-beats-audio-in-ubuntu/

  • is there any way to write terminal scrip for this?
    – D M
    Mar 30, 2018 at 7:35
  • 1
    this no longer works on 18.10 - when i click apply now it tells me device or resource busy
    – user230910
    May 6, 2018 at 8:49
  • 1
    In Ubuntu 18.10 you can't use "Apply Now" option to test, but directly set "Install Boot Override" and test it in the next reboot.
    – Nothor
    Jan 26, 2019 at 10:18

Please note that Steps 1 and 2 above no longer work as written.

Rodrigo Tessarollo's fix worked but he did not detail what changed. David Henningsson's PPA 'HD audio related stuff' at https://launchpad.net/~diwic/+archive/ubuntu/hda has not been updated since 14.04. His alsa-tools-gui which includes hda-jack-retask is now in the Ubuntu repositories.

Step1 is now install alsa-tools-gui via terminal with sudo apt-get install alsa-tools-gui or with Synaptic or some other Package Manager. It does not show up in the new 16.04 Ubuntu Software Center.

Step 2 is to enter "HDAJackRetask" into the Unity Dash to open the app. Note the way it is written.

Then follow step 3 on as stated above by @Bipin Paudel.

  • This worked for me on the latest Pop!_OS 19.10 on my HP Envy 17" TouchSmart, now have fairly decently working speakers on Linux. Mar 7, 2020 at 11:09

I had the same issue with my HP Pavilion DV6, and solution is probably the same:

Open the terminal, type sudo gedit /etc/modprobe.d/alsa-base.conf and add the next line:

options snd-hda-intel model=ref

where ref is Your laptop model, typed in the same order as your default hostname during installation of ubuntu.

Mine for example was:

options snd-hda-intel model=HP-Pavilion-DV6-7031tx

Then, restart the device and see if it works. If not, here is useful solution on how to do that, but I do not know if it will work on Your model.

Beats audio driver for hp dv6-7040tx


The only solution that I have found so far is to retask the audio using "HDAJackRetask" which is part of the "alsa-tools-gui" package.

This worked for me on my Pavilion DV6 7014NR running ubuntu 15.04 x64.

You can follow this tutorial, simple and fast & graphical way: http://www.smittix.co.uk/beats-audio-subwoofer-not-working-correctly-ubuntu-14-04/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .