0

I recently bought a lenovo ideapad s210 and installed Ubuntu 13.10 on it.

Overall it works pretty good, but I can't figure out how to get the internal microphone to work.

I've tried adding in lines to the /etc/modprobe.d/alsa-base.conf file as has been suggested in this thread Lenovo Ideapad built-in mic not working in 12.04.

But still no luck.

How to fix this?

0

I have same problem.

I can get the mic to work in audacity if I select hw:0,0 as mic input.

But, I cannot get it to stay as default.

It seems the problem comes down to both mic inputs (internal mic & headset input on side) being detected, but only one being able to be seen by gnome.

I could not get it set permanently, no matter what I tried. I tried using pacmd, but to no avail.

I have seen it working in Ubuntu 12.04.3 LTS, when a colleague installed it on the S210. And in that case 2 mics were listed in the sound setting.

If you plug in a headset with a mic, you'll see that it works, cause that's what it's set to.

Oddly, if I launch pavucontrol, and set it to microphone, it will work while it is open. But it won't stick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.