30

I recently downloaded the Lubuntu 12.04 LTS ISO for Power PC (I want to install it on an old iBook G4), but when I go to select the ISO in Startup Disk Creator, it just remains blank in the Source disc image (.iso) or CD: area.

Here is the screenshot from before (and it looks the same afterwards) selecting the ISO.

screenshot of startup disc creator

As you can see, the ISO is on the desktop separate from any other ISOs, IMGs, etc.

I read this question: Startup Disk Creator is not showing the ISO image, but that didn't help. Neither did Startup disc creator not allowing any iso to be loaded or Why isn't Startup Disk Creator working in 12.04?.

Two of those are 12.04 and one is 12.10, so they are both not my version, if that changes anything.

Does anyone have any clue why this is? I am going to attempt it with Unetbootin and if that fails, manually via the terminal and dd.

3
  • ya that happened to me too then i loaded win8.1 iso before loading ubuntu and then it recognized. If you have anyother iso try loading it before loading lubuntu
    – Meow
    Dec 27, 2013 at 3:30
  • Don't use Startup Disk Creator, it only messes with filesystem. Several really bad experiences with it, that I never had with Unetbooting for instance...
    – Quidam
    Apr 24, 2020 at 20:10

8 Answers 8

46

Yes, It is irritating, that the .iso files are NOT being identified, certainly a bug.

Rename the .iso file to end with .img, and the usb-creator-gtk(startup disk creator) would identify it.

mv something.iso something.img

Filed https://bugs.launchpad.net/bugs/1931493

6
  • 8
    Renaming the extension to .img works for me
    – fsevenm
    Feb 7, 2020 at 11:11
  • 1
    Startup Disk Creator wasn't recognizing Pop!_OS 20.04, renaming with a .img extension did the trick. May 19, 2020 at 2:18
  • 1
    This has allowed Startup DIsk Creator to actually bring the file into the menu for me to put on the USB!! Thank you!!! I'm in the process of burning the "image (img)" lol onto the USB right now. I will update this comment later to state whether I managed to successfully install Windows on my other computer using this method or now. May 31, 2020 at 22:50
  • 1
    You nailed it man! thank you.
    – Player1
    Jun 3, 2020 at 10:38
  • 1
    Where is the official bug report for this myopic behavior. It shouldn't matter if I have an ISO or a IMG file: the program should do what is necessary to write the image to the thumb-drive! Another stupid thing that never goes away is the UI of this application: it launches half-minimized, and even when manually maximized, it gives hardly any vertical room to list image files or thumb drives. This is one area where Rufus (a windows applications) is superior. May 30, 2021 at 19:55
10

Not a solution but as an alternative, you could try unetbootin:

http://unetbootin.sourceforge.net/

It recognized any kind of bootable iso I've tested, even FreeBSD and other *NIX.

If you don't like installing it from the bundle in the website, you can add this ppa:

sudo add-apt-repository ppa:gezakovacs/ppa
sudo apt-get update
sudo apt-get install unetbootin
3
  • Thank you. I mentioned I was going to try that in my question, and it recognized and "burned" the ISO to the USB disk. However, it didn't answer my original question, why doesn't Startup Disk Creator recognize the ISO? +1 for a good alternative! Dec 27, 2013 at 1:17
  • Startup disk creator did not recognize my Windows XP ISO, but this one did. Thanks!
    – Minas Mina
    Feb 14, 2016 at 15:42
  • This didn't work for me trying to create a bootable disk for Manjaro. It ran through successfully, but on booting the screen said "this is not a bootable disk".
    – Zoltán
    Apr 22, 2018 at 20:47
9

I found a "fix"

Startup Disk Creator looks in the Downloads directory by default. If finds any ISOs it sticks and will only let you use that ISO with the highest number and Ubuntu in its name. I solve this by moving ALL the ISOs from my Download directory in another directory. Startup Disck Creator can't default to any ISO so it comes up blank. It will then let you select ISO's from other directories as normal.

My exact process is:
1. Move all ISOs from ~/Downloads to ~/Downloads/ISOs
2. Run Startup Disk Creator, Source table will be blank
3. Click Other...
4. Open ISOs from any location as normal (in my case ~/Downloads/ISOs)

Hope this helps

This is only based on my computers running 12.04.4. Your mileage may differ.

1
  • not worked for me :(
    – Bimal Grg
    Jan 27, 2019 at 13:35
4

It appears that the "Startup Disk Creator" doesn't allow you to select corrupted .iso files.

To check if your .iso file is not corrupted, match the output of:

md5sum <downloaded>.iso

with the corresponding has here. If there's a mismatch, you're file is corrupted.

1
  • This was the problem for me for 20.04 iso. Here is the updated link to download the SHA256SUMS file to compare to the md5sum output.
    – JayDin
    Apr 20, 2021 at 23:27
4

Another option is to use the "Disks" application (a.k.a gnome-disk-utility, a.k.a. gnome-disks) which comes preinstalled with Ubuntu running Gnome (17.10 and up). I've just managed to create a bootable disk for Manjaro like this

  • Start the application from Dash ("Disks") or from terminal (gnome-disks)
  • In the list of drives, select your USB
  • Click any existing partitions on the disk
  • Click on the cogs icon
  • Click on "Restore partition image"
  • Select "Image to restore" and browse to your .iso file
  • Click on "Start restoring..."
3

I am trying to create a bootable usb to install windows10 in my friends computer but this unetbootin does not serve my purpose. The usb made bootable by unetbootin is not detected by windows.

I found the solution here. For quick turnaround I paste the solution here

sudo add-apt-repository ppa:colingille/freshlight
sudo apt-get update
sudo apt-get install winusb
1
  • Does not work on version 16.04. Looks like ppa needs to be updated for this version.
    – sureshvv
    Dec 9, 2017 at 6:29
2

This worked for me and is just an addition to the answer given by @S471 above.

Two simple steps to be followed :

  1. Rename the .iso file to end with .img file.

  2. In Startup Disk Creator, to be able to allow it to detect a .img file, change the default option, i.e from CD Images --> Disk Images in the bottom right corner dialog box.

  3. Now, you will be able to select the .img file,click open and select make startup disk to initialize mounting.

This works cleanly.

p.s-wanted to post this as a comment in @S471's answer.

2
  • 1
    Apparently, no one has ever fixed this bug; I'm having to do this same silly work-around in Kubuntu 20.04. It is pretty stupid that the program cannot auto-detect what to do for both iso and img files. Surely such issues can be automated away! May 30, 2021 at 17:22
  • 1
    I agree. Such minor hassles best left automated to let Linux users increase productivity.
    – kedarb
    May 30, 2021 at 18:06
2

With mine, it didn't see .ISO, but it did see .iso. However, it still wouldn't open until I renamed it to .img

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.