7

I want to install upstart to my ubuntu server 13.10, but I am confused if I need to download the source or install package. In upstart's getting started page I think they instruct to install the source.

But here and here they seem to say that upstart is included with later distributions. I tried initctl in the shell and I got missing command error. Does this mean I need to install it from source? I am new to ubuntu so I would appreciate if you can explain how I can install upstart.

  • A "typical user" should not even bother with that kind of stuff. What are you trying to do? What is the real problem? – ignis Dec 27 '13 at 0:25
  • I am trying to follow the instructions here groups.google.com/d/msg/clojure/lnGvHyRzX7w/N8eDnwJPXuAJ to start and stop the server with an upstart job. – Zeynel Dec 27 '13 at 0:32
  • Please open a specific question for that. As you see in my answer, Upstart is certainly present on your machine. – ignis Dec 27 '13 at 0:34
9

You do have upstart installed. In fact, the webpage you linked reads: Ubuntu has had upstart installed as a replacement for init scripts since as far back as 2006, but it hasn’t yet been really used until the latest beta release of Karmic (Ubuntu 9.10). and Upstart home page lists Ubuntu 6.10 and later as using Upstart.

To learn initctl usage, type initctl --help or man initctl.

The message

user@ubuntu:~$ initctl
initctl: missing command
Try `initctl --help' for more information.

is printed by initctl and implies that it is installed and executable, otherwise the shell would rather print initctl: command not found. In fact, which initctl returns /sbin/initctl on my machine.

  • 1
    Great, thanks. I read the above quote but upstart page confused me. Thanks, for clarifying. – Zeynel Dec 27 '13 at 0:38
2

To check what version of upstart you are running:

initctl --version

Expect output similar to this:

initctl (upstart 1.5)
Copyright (C) 2012 Scott James Remnant, Canonical Ltd.

This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

To check what version of Ubuntu you are running:

lsb_release -sd

Expect output similar to this:

Ubuntu 12.04.4 LTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.