3

When trying to ssh into my ubuntu instance, I receive -bash: ssh: command not found. I'm trying to connect to an instance on amazonaws. Im running cygwin off of windows 7

  • good question ... issue also happens when attempting to ssh out from a Ubuntu docker container which for efficiency does not include ssh client – Scott Stensland Oct 21 '17 at 20:56
6

Is ssh installed?

sudo apt-get install openssh-client

It is saying that you do not have ssh.

UPDATE:

If on cygwin (look here):

cd /to/where/cygwin/is
setup-x86.exe -q -P openssh

Or if its 64bit:

cd C:\Cygwin
setup-x86_64.exe -q -P openssh

You may have to run it as administrator or try reinstalling cygwin and make sure the little ssh box is checked.

| improve this answer | |
  • Im running cygwin off of windows 7 – james Dec 26 '13 at 20:48
  • Please include this information in your question. – jmunsch Dec 26 '13 at 20:50
  • Did not see the ssh box in the installation box. I re downloaded cygwin with all default settings. – james Dec 26 '13 at 21:25
  • Have you tried navigating to the cygwin directory and trying the above commands in CMD? Also, This might be off topic and may find better support in a different forum. – jmunsch Dec 26 '13 at 21:27
  • Im using the setup kernel now. Everything seems to be getting the same response: command not found. Thank you! – james Dec 26 '13 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.