7

I know how to change gnome's terminal font using the gui enter image description here

But I would like to do the same using the terminal (automated way). How can I do that ?

9

I have just found out that I can do this with gconftool-2, e.g. :

 gconftool-2 --set /apps/gnome-terminal/profiles/Default/font --type string "Ubuntu Mono derivative Powerline 11"
2
  • Strange, that didn't work for me. The setting changed, but the terminal font didn't. – Costa Jan 16 '15 at 16:49
  • Seems I had to go to profile preferences in the terminal and uncheck 'use system default fixed width font' – Costa Jan 16 '15 at 16:50
4

To also uncheck the Use the system fixed width font checkbox from the command line, use:

gconftool-2 --set /apps/gnome-terminal/profiles/Default/use_system_font --type=boolean false

Tested on Linux Mint Cinnamon 17.1. Your mileage may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.