My Brother DCP 7055W does not scan. I can print ok, but the scanner won't work.

I am running Ubuntu 13.10 32- bit on AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ × 2.

In the previous version of Ubuntu and with another Printer/Scanner Simple Scan and Printing was working fine.

Now after the update -

I can print-OK. But when I try printing 2 pages on one page, it shows it corrrectly in the preview but as a print the pages come out in the portrait form with one and a half page print in landscape on it.

From http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#DCP-153C , I have installed the cupswrapper driver and lpr driver.

How can I fix it so that when I want to print two pages on one, it does what I want it to do???

Now with the scanner

I have installed from the http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_scn.html the scan-key-tool 32bit and the brscan 32-bit. I have tried uninstalling, then re-installing, xsane and Simple Scan (through synaptic), but it still wont work.

For some reason in Synaptic Package Manager, the only entries under Brother are the lpr, cupswapper, & brscan-skey files, the Br scan file is not listed.

Simple scan reports "Failed to scan. Unable to start scan, & XSane reports " Failed to Start scanner: Invalid Argument.

With the windows laptop, it is perfectly printing, scanning and even scanning over wireless.

I have tried numerous times to get the scanner running, and printer to print properly the two pages on one, but to no avail. Argghhhh...... I hate to have to start the windows laptop scan and then transfer to the Ubuntu desktop.

Any help will be sincerely appreciated.

Many thanks.


  • Did you try to run simple-scan with sudo (sudo simple-scan)? I am able to scan on my DCP-7055 with standard drivers installed only with sudo previliges.
    – Kaisuj
    Mar 19, 2014 at 16:25

5 Answers 5


Wireless printing

Download the LPR and cupswrapper driver from: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#DCP-7055W

Install them:

sudo dpkg -i dcp7055wlpr-*.deb
sudo dpkg -i dcp7055wcupswrapper-*.deb

New printer should be added and ready for use now.

Wireless scanning

Download brscan4 and scan-key-tool from: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_scn.html#brscan4

Install them:

sudo dpkg -i brscan4-*.deb
sudo dpkg -i brscan-skey-*.deb

Voila, wireless scanning using simple-scan works!


For what it's worth I am also having problems with getting scanning to work with a Brother printer/scanner; I did find some clues that may help though. I can print (after installing the driver from Brother's site it didn't work - would show up in the list of printers, grumble in the error log about "Highest" not being a valid resolution and so on, but otherwise silently fail to print, then I saw something about their 64-bit drivers not really being 64-bit, and eventually - possibly thanks to apt-get install lib32gcc-4.8-dev of all things - it would print).

But with all the info on the net I still cannot scan. I have the Brother brscan2 and brscan-skey-0.2.4-1 (the latter might not be a good idea?), but sane-find-scanner does not find it (in fact gives an error: could not fetch string descriptor: Pipe error) but scanning does work with my HP Deskjet 1510 that is also attached by USB, and scanimage -L finds it.

I am using (64-bit Intel) Kubuntu 13.10 (also failed with recent Ubuntu that I had installed before) but I am pretty sure it did work with an earlier Fedora install (on a 32-bit system). I have both USB and network connections to the MFC-5860CN, and only USB to the HP1510.

Things people seem to say might be the problem:

  1. CUPS (since v 1.4?) CAN INTERFERE WITH MULTIFUNCTION PRINTERS working as scanners?
  2. Brother proprietary drivers: 32-bit good, 64-bit troublesome?
  3. brscan-skey may be a problem??
  4. Instructions on Brother site miss important steps involving /usr/local/Brother/sane/setupSaneScan2 -i ??
  5. need to reboot and/or re-plug the USB cable?

I cannot say any of these ideas actually got my scanner going. But it may be food for thought.

  • Could you describe without paraphrasing how you solved the problem (if it's the same as OP).
    – Braiam
    Jan 16, 2014 at 18:33

I have that printer too and Xubuntu 13.10. For what it's worth, that's how I've installed the scanner. After dowloading the two files from http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_scn.html#brscan4 and forcing their installation as shown by V-tech

Start the driver in background

$ brscan-skey

Check scanner status

$ brscan-skey -l

This should appear, but don't worry if it doesn't...

 scanner           : brother4:net1;dev0  :         Active

Reserve an ip for the scanner in the control panel of your router.

Run the following command, modifying the first two parameters to your taste and the last inserting the your scanner ip.

$ brsaneconfig4 -a name=SCANNER-NAME model=SCANNER-MODEL ip=PRINTER-IP

Running the following command, you should see the scanner and its ip.

$ brsaneconfig4 -q | grep SCANNER-NAME

Now try to scan.


You can install drivers for Brother LPR driver and cupswrapper from Official Ubuntu Repository by:

sudo apt-get install brother-cups-wrapper-ac brother-cups-wrapper-bh7 brother-cups-wrapper-common brother-cups-wrapper-extra brother-cups-wrapper-laser brother-cups-wrapper-laser1 brother-cups-wrapper-mfc9420cn 

You can install scanner drivers by

sudo apt-get install sane xsane xsane-common sane-utils libsane libsane-common libsane-dbg libsane-dev libsane-extras libsane-extras-common libsane-extras-dbg libsane-extras-dev

Then you can use the printer with the application Printers and the scanning with Simple Scan.

sudo apt-get install system-config-printer-gnome simple-scan
  • hi there, many thanks for the answer. but still doesnt work. in the terminal i could run the first and the third command but the second one said E: Invalid operation installed. Simple-scan was already installed.
    – vsb
    Dec 26, 2013 at 14:36
  • You need to configure the printer and scanner with these applications.
    – user224082
    Dec 26, 2013 at 15:06
  • HI there, many thanks again for your help but i need some exact instructions as I am not well versed with linux. How do i configure the printer and scanner? In xsane I tried loading the Brother:DCP-7055W.drc file that i saw in /myhome/.sane/xsane but it doesnt load and desnt start. Then I tried scanning with simple-scan and there also i cannot change anything or configure printer/scanner. Your help is sincerely appreciated. Many thanks once again.
    – vsb
    Dec 26, 2013 at 17:13
Run the following command, modifying the first two parameters to your requirement and the last inserting the your scanner ip.

$ brsaneconfig4 -a name=SCANNER-NAME model=SCANNER-MODEL ip=PRINTER-IP

Running the following command, you should see the scanner and its ip.

$ brsaneconfig4 -q | grep SCANNER-NAME

Now try to scan.

This was the solution for Wireless Scannen with the Brother DCP-J4210DW. Thank you for ever :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .