23

I have a problem with thumbnails on my Ubuntu 12.04 LTS 32-bit system with Cinnamon 2.0.14 DE and Nemo 2.08.

I have tried removing the ~/.thumbnails directory but it is not working for me. This is very weird because when I open an image in Eye of GNOME, Nemo is creating thumbnails but other images doesn't have preview thumbnails as one can see in my screenshots below. I have changed the preview settings as show miniatures always.

Screenshot 1:

directory full of images

Screenshot 2:

settings

25

Nemo makes previews only for files less than one MB by default. You can change this from its preferences:

Screenshot

  • This worked for me in Nemo-2.4.4 – libregeek Feb 7 '15 at 4:05
  • I know this is an old question, but do you know how to set the size as a custom value? I'm looking for thumbs on files smaller than 25MB, any ideas? – Felipe Jul 4 '16 at 2:47
5

The solution below works for 32 and 64 bit systems (tested on cinnamon 17):

In your home directory remove the .thumbnails subdirectory:

rm ~/.thumbnails

Set a new link for the cache folder:

cd ~
ln -s .cache/thumbnails .thumbnails
0

To fully flush everything out consistantly, I ended up having to use a small script to clear out all the cached files and reset the symbolic link to the cache folder. This worked for both nemo and nautalus. I made sure to shut down the file manager at the end of the script too. Then when I next opened the folder, all the thumbnails reloaded. Be sure the file size for thumbnails is set high enough. I have a couple MP3 files over 10meg so I have my preview level set to 100meg.

#!/bin/bash

find ~/.cache/thumbnails/ -type f -exec rm {} \;
rm -rf ~/.thumbnails
ln -s ~/.cache/thumbnails ~/.thumbnails

killall nautilus    # in case you are using nautilus
killall nemo        # in case you are using nemo
0

The solution for my in Xubuntu 18.04 x386 is to delete these folders by putting in a terminal:

rm -fr ~/.thumbnails
rm -fr ~/.cache/thumbnails

then open Nemo and he will say a message that there is a problem with the cache of the icons:

repair cache

now he asks me to put my password

set password

And see, working fine:

here

0

I had this issue myself, I fixed it by doing the following:

rm -Rf ~/.cache/thumbnails ~/.thumbnails

So what this does it deletes the thumbnail caches to get rid of any broken or miswritten thumbnails. The end result I found is that the xplayer used in Linux Mint got corrupted somehow on disk, my solution to fix that was to reinstall xplayer, and now my thumbnailing works again

sudo apt install --reinstall xplayer xplayer-plugins xplayer-plugins-extra libxplayer0
  • ~/.local/share/nemo may contain the user's actions and scripts. I am pretty sure she does NOT want those deleted... – Roadowl Sep 3 at 13:21
  • I will check, I have actually gotten this issue resolved on my own machine now, I will update the answer soon – zeitue Sep 3 at 18:34

protected by Community Nov 14 '16 at 15:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.