29

I have a problem with thumbnails on my Ubuntu 12.04 LTS 32-bit system with Cinnamon 2.0.14 DE and Nemo 2.08.

I have tried removing the ~/.thumbnails directory but it is not working for me. This is very weird because when I open an image in Eye of GNOME, Nemo is creating thumbnails but other images doesn't have preview thumbnails as one can see in my screenshots below. I have changed the preview settings as show miniatures always.

Screenshot 1:

directory full of images

Screenshot 2:

settings

36

Nemo makes previews only for files less than one MB by default. You can change this from its preferences:

Screenshot

2
  • This worked for me in Nemo-2.4.4
    – libregeek
    Feb 7 '15 at 4:05
  • I know this is an old question, but do you know how to set the size as a custom value? I'm looking for thumbs on files smaller than 25MB, any ideas?
    – Felipe
    Jul 4 '16 at 2:47
5

The solution below works for 32 and 64 bit systems (tested on cinnamon 17):

In your home directory remove the .thumbnails subdirectory:

rm ~/.thumbnails

Set a new link for the cache folder:

cd ~
ln -s .cache/thumbnails .thumbnails
1

To fully flush everything out consistantly, I ended up having to use a small script to clear out all the cached files and reset the symbolic link to the cache folder. This worked for both nemo and nautalus. I made sure to shut down the file manager at the end of the script too. Then when I next opened the folder, all the thumbnails reloaded. Be sure the file size for thumbnails is set high enough. I have a couple MP3 files over 10meg so I have my preview level set to 100meg.

#!/bin/bash

find ~/.cache/thumbnails/ -type f -exec rm {} \;
rm -rf ~/.thumbnails
ln -s ~/.cache/thumbnails ~/.thumbnails

killall nautilus    # in case you are using nautilus
killall nemo        # in case you are using nemo
1

The solution for my in Xubuntu 18.04 x386 is to delete these folders by putting in a terminal:

rm -fr ~/.thumbnails
rm -fr ~/.cache/thumbnails

then open Nemo and he will say a message that there is a problem with the cache of the icons:

repair cache

now he asks me to put my password

set password

And see, working fine:

here

0

I had this issue myself, I fixed it by doing the following:

rm -Rf ~/.cache/thumbnails ~/.thumbnails

So what this does it deletes the thumbnail caches to get rid of any broken or miswritten thumbnails. The end result I found is that the xplayer used in Linux Mint got corrupted somehow on disk, my solution to fix that was to reinstall xplayer, and now my thumbnailing works again

sudo apt install --reinstall xplayer xplayer-plugins xplayer-plugins-extra libxplayer0
2
  • ~/.local/share/nemo may contain the user's actions and scripts. I am pretty sure she does NOT want those deleted...
    – Roadowl
    Sep 3 '19 at 13:21
  • I will check, I have actually gotten this issue resolved on my own machine now, I will update the answer soon Sep 3 '19 at 18:34
0

I am not sure I'm out of the woods, but a few things I noticed on my end.

Debugging

There are no Nemo logs I could find, but someone else suggested enable warning messages by running G_DEBUG=fatal_warnings gdb nemo. You can run this in the terminal, then in another window launch Nemo from the command line for a folder with problematic thumbnailing nemo /path/to/folder. This would show warnings from Nemo.

My findings

  • xplayer errors (xplayer-video-thumbnailer:21934): GLib-CRITICAL **: 10:34:21.307: Failed to set scheduler settings: Operation not permitted - At the recommendation from stack overflow, I had installed xplayer thumbnailer. This was unhelpful. I uninstall all the player stuff I had installed. sudo apt remove xplayer-thumbnailer xplayer xplayer-plugins xplayer-plugins-extra libxplayer
  • vidoe thumbnails For video, ffmpeg was enough - sudo apt install ffmpegthumbs ffmpegthumbnailer. If using Linux mint, you may need mint-meta-codecs.
  • raw thumbnails errors - Unable to create loader for mime type image/x-nikon-nef: Unrecognized image file format - I was getting a lot of these. I think this was my initial issue, but I didn't discover how to debug Nemo until later. The advice in this comment was the best I could find (also in summary below.
  • Hidden files? - at some point, it seemed that hidden files were blocking thumbnail generation. Deleting those seemed to help, but not sure if that was real.
  • pixel warnings - can be ignored, according to this. deprecated pixel format used, make sure you did set range correctly

Summary

  1. Remove xplayer if you have it installed (command above)

  2. For video thumbnails, install ffmpeg thumbnailer (command above)

  3. For raw files, update: Open up /usr/share/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer and edit it to read as follows:

    [Thumbnailer Entry]
    TryExec=/usr/bin/gdk-pixbuf-thumbnailer
    Exec=/usr/bin/gdk-pixbuf-thumbnailer -s %s %u %o
    MimeType=image/png;image/bmp;image/x-bmp;image/x-MS-bmp;image/gif;image/x-icon;image/x-ico;image/x-win-bitmap;image/vnd.microsoft.icon;application/ico;image/ico;image/icon;text/ico;application/x-navi-animation;image/jpeg;image/x-portable-anymap;image/x-portable-bitmap;image/x-portable-graymap;image/x-portable-pixmap;image/tiff;image/x-xpixmap;image/x-xbitmap;image/x-tga;image/x-icns;image/x-quicktime;image/qtif;image/x-3fr;image/x-adobe-dng;image/x-arw;image/x-bay;image/x-canon-cr2;image/x-canon-crw;image/x-cap;image/x-cr2;image/x-crw;image/x-dcr;image/x-dcraw;image/x-dcs;image/x-dng;image/x-drf;image/x-eip;image/x-erf;image/x-fff;image/x-fuji-raf;image/x-iiq;image/x-k25;image/x-kdc;image/x-mef;image/x-minolta-mrw;image/x-mos;image/x-mrw;image/x-nef;image/x-nikon-nef;image/x-nrw;image/x-olympus-orf;image/x-orf;image/x-panasonic-raw;image/x-panasonic-raw2;image/x-pef;image/x-pentax-pef;image/x-ptx;image/x-pxn;image/x-r3d;image/x-raf;image/x-raw;image/x-rw2;image/x-rwl;image/x-rwz;image/x-samsung-srw;image/x-sigma-x3f;image/x-sony-arw;image/x-sony-sr2;image/x-sony-srf;image/x-sr2;image/x-srf;image/x-x3f;
    

    If you've a raw.thumbnailer or similar in that folder, delete it.

  4. Clean up old thumbs:

    rm -Rf ~/.cache/thumbnails ~/.thumbnails
    killall nemo
    

Not the answer you're looking for? Browse other questions tagged or ask your own question.