0

I am using Ubuntu server 13.10 and I am trying to get my telnet to work. I am using a vpn service to test the remote connection. Connection:

MBMacBook-Pro:~ mb: telnet telnet.mysite.com 666
Trying IP...
telnet: connect to address IP: Operation timed out
telnet: Unable to connect to remote host 

But when I try it on my local network, it works. How can I get the telnet service to work for remote connections?

1

A firewall may be blocking your connection.

There can be two cases:

  • Firewall on the server is blocking incoming access to port 666. (This may include firewall on the server and an additional layer of firewall if you are using a cloud service like Amazon EC2)
  • Firewall on your client machine may be blocking outgoing access to port 666.

In any case you need to add an exception to port 666 in the relevant machines.

  • The firewall on the server is just fine and the client machine isn't either I've already tried my routers any other tips – user228825 Dec 26 '13 at 8:01
  • Can you ping the host from the remote machine? $ ping telnet.mysite.com – Shirish Mishra Dec 26 '13 at 9:36
  • yes I can! But on the computer I am trying to connect from uses vpnbook it can ping but not connect if that is of any help at all – user228825 Dec 26 '13 at 9:49
  • If it is not a security issue try to: 1. temporary disable the firewall using $ sudo ufw disabled 2. Try using the IP address directly in telnet command, $telnet ServerIP 666 3. If you can access the server without VPN try to do the above operation outside the VPN. – Shirish Mishra Dec 26 '13 at 10:35
  • I have already tried that it still failed the canyouseeme.org did work for ports 20-30 that I have all opened for the telnet operations – user228825 Dec 26 '13 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.