I've installed the lastest Nvidia driver for my Graphic Card (a .run file), I've followed Nvidia instructions (http://us.download.nvidia.com/XFree86/Linux-x86/331.20/README/index.html) and placed .run file in home, then I Ctrl+Alt+F1:

cd ~
sudo source lightdm stop
sudo sh NVIDIA-Linux-x86-133.20.run #(and I installed the driver)
sudo source lightdm start

After doing this every time I switch on the PC after the booting screen I can see just a black screen with a flashing underscore and I can't do anything, even open the terminal with Ctrl+Alt+F(n). I no longer see an Nvidia logo after the booting screen.

I tried to use recovery mode and (with "Drop to root shell prompt" mode) type sudo source lightdm start, but it gave me an error, then I tried sudo rm /etc/X11/xorg.conf, but it couldn't find the file, then I tried to uninstall and reinstall anything related to Nvidia as shown here: Blank screen after installing nvidia restricted driver, but nothing.

What should I try in your opinion?

1 Answer 1


Try removing bumblebee that is reported to be the source of problem with latest Nvidia drivers:

sudo apt-get --purge remove bumblebee

If this doesn't work, try purging all propietary Nvidia installed through the .run file, reinstall nvidia-331 through PPA, then remove/purge bumblebee.

This worked for me in 13.10 (x64): Problem with Nvidia driver 331.20 on ubuntu 13.10 (64bit)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.