It seems while the 173 driver is installed, my resolution settings are not loaded when I log in or reboot. I've tried opening nvidia-settings as superuser and user, changed the resolution, applied, then saved it to the default xorg conf file (while giving my password when needed.). Nothing I do seems to fix this issue.

If anyone could help, that'd be great.

(Running the equivelant of Ubuntu 10.04 I think, when I'm actually on Mint. (Kernel 2.6.32-24-generic #42-ubuntu)

xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL D1028L"
    HorizSync       30.0 - 69.0
    VertRefresh     48.0 - 120.0
        Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5500"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1024x768 +0+0"
    SubSection     "Display"
        Depth       24

2 Answers 2


You have to explicitly save them.

Try running nvidia-settings with root privileges:

gksu nvidia-settings

Then go to "X-Server Display Configuration", setup your resolution and possibly meta-modes and click "Save to X Configuration File"

Close Nvidia-settings. They are now saved.

  • I guess I'm confused by your instructions. Am I supposed to set my resolution somewhere other than the X Server Display Configuration tab? That's where I've always been doing it, and by the chronology of your instructions, it seems that the resolution should be set elsewhere.
    – gcode
    Commented Sep 10, 2010 at 19:43
  • @TGP1994 You are right, I formulated my instructions in a confusion manner. The point was, you need to save the settings to your xorg.conf and you can only do that as root.
    – Ralf
    Commented Sep 11, 2010 at 0:22
  • 1
    Well, unfortunately, that's one of the many things I've tried already :( Any other ideas? (If you wouldn't mind supporting it as a bug report, I've created it here: bugs.launchpad.net/ubuntu/+source/nvidia-settings/+bug/634648)
    – gcode
    Commented Sep 11, 2010 at 2:24
  • Hmm. That works here and you don't mention actually clicking on the 'save to X configuration file' button. And you also don't mention if you launched it usin gksu or not. I've mentioned intentionally. You need to be root to overwrite your xorg.conf
    – Ralf
    Commented Sep 11, 2010 at 11:05
  • I'm pretty sure that's why it prompts you for a password when you go to save the configuration file, right? To get root privileges to overwrite the file? And when I said saved to /etc/X11/xorg.conf, that would imply that I've clicked the save to X configuration file button :)
    – gcode
    Commented Sep 11, 2010 at 14:31


It seems to be fixed after the recent kernel update, 2.6.32-25. After applying that update and rebooting, NVIDIA kept crashing gdm, and I was given several options. I chose the option of creating a new (default) xorg.conf file. I did so and rebooted, and suddenly, everything works fine! Even the resolution not sticking has been fixed!

Thank you Ubuntu developers, and you especially Ralf, for helping me along here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .