19

I've been getting an issue since upgrading to 2.6.39 in Natty from the Kernel-PPA repository.

When I do a sudo update-initramfs -u I get the following error message.

update-initramfs: Generating /boot/initrd.img-2.6.39-0-generic-pae
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169

I did notice that firmware wasn't in the allocated directory. Does anyone know where to get the firmware files for this.

12

There's a solution at http://www.davidgis.fr/blog/index.php?2011/05/06/800--resolu-solved-w-possible-missing-firmware-lib-firmware-rtl_nic-rtl8105e-1fw-for-module-r8169. Essentially you need to do:

git clone git://git.kernel.org/pub/scm/linux/kernel/git/romieu/linux-firmware.git
sudo cp -r linux-firmware/rtl_nic/ /lib/firmware/

and then sudo update-initramfs -u works without errors.

  • Cheers I'll check it out. – Dean Thomson May 11 '11 at 4:08
  • 2
    This repo is now fatal: remote error: access denied or repository not exported: /pub/scm/linux/kernel/git/romieu/linux-firmware.git. I get this error now on 14.04 with 4.4.1 kernel. – Patryk Feb 27 '16 at 22:05
  • 1
    Is there an updated siolution for this as neither this nor Alex's answer's work – Anshuman Kumar Nov 5 '20 at 10:03
38

Do sudo apt-get install firmware-realtek and the problem should be solved

  • Is this a real package? On my 11.04 system, apt-cache show firmware-realtek returns a message saying the package doesn't exist. – djeikyb Aug 10 '11 at 0:53
  • 9
    This package is in the Debian repos - it is not in the Ubuntu repos - so the answer is only applicable to Debian not Ubuntu. – fossfreedom Oct 24 '11 at 19:37
  • 1
    You will also have to add access to the non-free repositories. Debian 9 guide: blog.programster.org/debian-9-install-raeltek-firmware – Programster Sep 9 '17 at 9:01
6

I had the same problem whit Ubuntu 12.04.5 LTS. Today I have tested, but the old "git://git.kernel.org/pub/scm/linux/kernel/git/romieu/linux-firmware.git" is a broken link.

I have searched the new git url for dowload the firmware of realtek. The commands that I have tested (and works very well) are:

git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
sudo cp -r linux-firmware/rtl_nic/ /lib/firmware/
sudo update-initramfs -u

and

rm -rf linux-firmware

For deleting the directory that git has downloaded.

5

Perhaps a better answer is to install linux-firmware package and if necessary linux-firmware-nonfree package.

4

Recently I have faced the similar issue, but when I have followed the Rocko method, the link is broken. So it was not making it download the linux-firmware.

Also I have tried to do: sudo apt install firmware-realtek, still it didn't worked out.

After searching it online, found a new link of git. git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

Steps to follow:

  1. Download the linux-firmware: $ git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

  2. copy the missing firmware to /lib/firmware: $ sudo cp -r linux-firmware/rtl_nic/ /lib/firmware/ $ sudo cp -r linux-firmware/i915 /lib/firmware/ (In my case i915 was also missing)

  3. update the initramfs: $ sudo update-initramfs -u

Note: After update, if still see that, some of the firmware are missing, then search it in linux-firmware and copy those folders into /lib/firmware.

2

For Debian, I run the following command, and it really works:

apt-get install linux-firmware-nonfree
2

It seems that the linux firmware package is corrupt, I solved this issue in ubuntu 13.04 by

sudo apt-get purge linux-firmware

and

sudo apt-get install linux-firmware
1

The file /lib/firmware/rtl_nic/rtl8105e-1.fw is in the package firmware-realtek

You need to run following command. Open terminal Ctrl + Alt + T :

sudo apt-get install firmware-realtek

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.