Wifi connection might drop spontaneously or simply cannot connect. Users on Ubuntu 10.04 and 11.04 have reported experiencing the problem.

Running dmesg would show:

[210749.637705] wlan0: deauthenticating from 00:23:89:48:3b:b0 by local choice (reason=3)
[210778.632244] wlan0: deauthenticating from 00:23:89:48:3b:b0 by local choice (reason=3)
[210784.456359] wlan0: deauthenticating from 00:23:89:82:75:70 by local choice (reason=3)

which is pretty cryptic.

I have tried: kill -9 wpa_supplicant, but wpa_supplicant keeps getting restarted each time.

Also, some have suggested that this was caused by enabling power management. However, this might not be true, as the problem has presented itself in a situation where power management was disabled.

  • I have this problem in Natty-11.04 too, after some research they say it is caused by the power saving settings. Are you on a laptop? On battery? I tried issuing sudo iwconfig wlan0 power off but the problem still remains. – jonallard Sep 21 '11 at 15:33
  • @foss Here's mine (gist) – jonallard Sep 28 '11 at 21:05
  • @jonallard - can you add to that the router encryption you are using (wep/wpa etc) as well as the interface type e.g. b/g/n, your channel number and what country you are in. – fossfreedom Sep 28 '11 at 21:15
  • @foss In my case, WPA2-Entreprise is being used with PEAP/MSCHAPv2, in Canada. I do not have other information for the moment. – jonallard Sep 28 '11 at 22:20
  • @foss iwlagn: Unknown parameter 'lln_disable' – jonallard Sep 29 '11 at 15:42

According to this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/548992

The problem is larger than only Ubuntu but affects more Linux Distributions as well.

In the RedHat bug they suggest that it is most likely IPv6 which is causing the issue. If you are not using IPv6 on your WiFi network, change the setting in the network manager to IPv6 Ingore (Negeren in the Dutch version)

[when your network migrates to IPv6 you can turn this setting back on again http://en.wikipedia.org/wiki/IPv6 ]

The RedHat bug is here: https://bugzilla.redhat.com/show_bug.cgi?id=590202

make sure that if you are having this issue to participate in the Ubuntu Bug by adding any extra information that is helpful, such as your findings on wpa-supplicant and by clicking the Affects Me button, the more people who report it the more priority it will get. Thank you for taking the time to make Ubuntu Better for all of us.

NetworkManager Wifi to IPv6 ignore

| improve this answer | |

I had this problem using 11.04 on a lenovo S12 (Intel atom) laptop.

The solution for me was to remove Network Manager and Install Wicd.

I found wicd easy to use and very reliable, although it is no longer supported.

Chris' blog had the answer that worked for me.

I also had to workaround a acer_wmi bug on the laptop.

To replace Network manager, use the following command…

sudo apt-get install wicd && sudo apt-get remove network-manager*

I have since replaced 11.04 with 11.10 and did not need wicd. It seems that there were some excellent improvements in Network Manager.

NOTE: seems my faith in Network Manager was Premature. It has stopped working and I have switched to Wicd.

Good Luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.