I recently installed a fresh copy of Ubuntu 13.10 onto a USB hard drive using unetbootin(which used extlinux as the initial bootloader during install) and have been having problems where GRUB2 isn't loading when the USB drive is selected from the BIOS boot menu. During boot, if the USB drive is selected from the BIOS boot menu, I am left with a black screen.

The installation went well, and the system runs just fine, but I am unable to boot into it unless I use the GRUB2 from my Debian installation that's installed on my internal hard drive.

I have tried numerous times to purge and reinstall GRUB2, but have yet to be successful. I have tried both grub-install, grub-update(thinking that maybe the menu entries were broken), apt-get to purge grub(thinking that GRUB might be corrupt), as well as using dd to purge grub from my MBR entirely and then reinstalling it.

The USB hard drive is formatted with a single primary EXT4 partition and nothing else.

Any help would be greatly appreciated.

Thank you in advance,



I just ran into this same problem installing 14.04 from a USB disk. It didn't even get to Grub menu; after I selected to boot off the USB drive, the system just stayed on black screen with the hard drive activity LED indicator staying on.

Solution: On the USB stick, navigate to and open in an editor the file /boot/grub/grub.cfg Change the line

set gfxmode=auto

(line 2?) to

set gfxmode=640x480;auto

Save file and Reboot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.