63

Is it possible to show the seconds on the clock in GNOME 3?

80

Not sure when this path changed, but as of Ubuntu 13.04 the seconds display can be set in the terminal with:

gsettings set org.gnome.desktop.interface clock-show-seconds true

To turn seconds display off:

gsettings set org.gnome.desktop.interface clock-show-seconds false

and checked with:

gsettings get org.gnome.desktop.interface clock-show-seconds
| improve this answer | |
  • 2
    For those who prefer the GUI way, @MichelSamia gives another answer based on gnome-tweak-tool – Didier L Jun 16 '17 at 17:28
  • 3
    Still works in Ubuntu 18.04 LTS, thanks! – pzrq May 12 '18 at 5:02
  • At first it did not work on my Debian 9. It gave: (process:23119): dconf-WARNING **: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY. I checked the value of $DISPLAY and it was blank! So I started a new terminal, $DISPLAY was :0 and this time it worked. – Gabriel Devillers Nov 14 '18 at 16:01
  • Still works in Ubuntu 19.10, thanks! – DeviOS Apr 6 at 3:39
  • Works in Fedora 32 as well – Water May 1 at 18:17
30

GUI way:

  1. launch gnome-tweak-tool, sometimes called Advanced Settings
  2. click the Top Bar menu
  3. enable Show seconds
| improve this answer | |
  • I found this on my new RHEL 7 VM was called "Tweaks". It was a separate application from "Settings". – ArtOfWarfare May 18 at 19:51
15

Yes, run this command in a Terminal:

gsettings set org.gnome.shell.clock show-seconds true

And you can verify with:

gsettings get org.gnome.shell.clock show-seconds

Or you can install dconf-tools Install dconf-tools and use dconf-editor to browse to org.gnome.shell.clock

| improve this answer | |
  • Did any updates change this path? Or it could be related that I'm not using ubuntu? – RSFalcon7 Oct 15 '13 at 19:06
  • @RSFalcon7 if you are not using Ubuntu you are on the wrong site. – Thomas Ward Nov 14 '13 at 21:03
  • 1
    @ThomasW. I just think it is quite pointless to start another discussion with the exact same topic has this one in Unix.SE, because GNOME 3 is the same everywhere... Anyway this is not on topic here – RSFalcon7 Nov 15 '13 at 10:42
  • 1
    No such schema 'org.gnome.shell.clock' → gsettings set org.gnome.desktop.interface clock-show-seconds true – Dereckson Jun 4 '16 at 23:14
1

For MATE Desktop (the continuation and fork of GNOME 2 with GTK+ 3 support), you can achieve this using the graphical user interface (GUI)!

  • Right-click on date and time:
    enter image description here
  • Go to Preferences
  • Now enable the Show seconds
    enter image description here

The end result:
enter image description here

Drink beer and Vote me up, cause it rocks!

| improve this answer | |
1

The most user-friendly way to do this, (on 20.04 LTS) seems to be:

sudo apt install gnome-tweak-tool

and then launch "Tweaks" either by searching for it in Applications menu or launching gnome-tweak-tool from terminal.

From there you'll see something like this:

Gnome Tweak Tool - Top Bar seconds adjustment

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.