0

I need to install some stuff but it says I need to remove Linux Kernel Image for version 3.11.0-12-generic and Linux Kernel extra for version 3.11.0-12-generic. Please help.

miles@Ubuntu-PC:~$ sudo apt-get install -f
[sudo] password for miles: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-image-3.11.0-12-generic linux-image-extra-3.11.0-12-generic
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 183 MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 185492 files and directories currently installed.)
Removing linux-image-extra-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
update-initramfs: Deleting /boot/initrd.img-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
/usr/sbin/grub-mkconfig: 11: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-extra-3.11.0-12-generic.postrm line 328.
dpkg: error processing linux-image-extra-3.11.0-12-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Removing linux-image-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
update-initramfs: Deleting /boot/initrd.img-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
/usr/sbin/grub-mkconfig: 11: /etc/default/grub: splash: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.11.0-12-generic.postrm line 328.
dpkg: error processing linux-image-3.11.0-12-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 linux-image-extra-3.11.0-12-generic
 linux-image-3.11.0-12-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

/etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash profile”
GRUB_CMDLINE_LINUX=""
  • Welcome to AU! This looks like an unconfigured package issue. Can you run sudo apt-get install -f and append or attach the output to your question? – David Foerster Dec 21 '13 at 18:39
  • Okay I did that is says I need to remove 2 things and it gave me an error what do I do know and thank you so much for helping – Miles Dec 21 '13 at 18:44
  • The Error is Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.11.0-12-generic.postrm line 328. dpkg: error processing linux-image-3.11.0-12-generic (--remove): subprocess installed post-removal script returned error exit status 1 Errors were encountered while processing: linux-image-extra-3.11.0-12-generic linux-image-3.11.0-12-generic E: Sub-process /usr/bin/dpkg returned an error code (1) – Miles Dec 21 '13 at 18:46
  • There seems to be a problem with the configuration file /etc/default/grub. Can you append that to your question as well (if it's short enough), or upload it to a paste service and link it here? – David Foerster Dec 21 '13 at 19:34
  • Perhaps try sudo apt-get autoremove first. – douggro Dec 21 '13 at 19:38
2

You cannot install anything because there are broken packages on your system. Considering the output of apt-get install -f, their removal fails because of an error in your /etc/default/grub, line 11:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash profile”

Those aren't the quotation marks you're looking for. You need a pair of either " or ' instead. You can change them manually or with

sudo sed -i -e 's/”/"/g' /etc/default/grub

Afterwards you can retry to remove those broken packages (sudo apt-get install -f).

  • Thank you I needed to install some stuff for touch screen thank you so much – Miles Dec 21 '13 at 19:53
  • If this answer resolved the issue, please consider accepting it. – David Foerster Feb 10 '14 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.