2

I can see that this has been asked here several times before, but no one seems to have an answer or to be willing to give it, so I ask again.

After reading through a dozens of tutorials, I finally managed to get my Broadcom 4312 to work. But after every reboot, I have to do manually a

$ sudo modprobe b43

Then, after 20-30 secs, the WLAN connection is etablished. What can I do to circumvent this?

I am running Lubuntu 13.10 and have a

0b:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1395 WLAN Mini-Card [1028:000b]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at fe7fc000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: b43-pci-bridge

(BTW, why is the model number 4312, but the subnumber in the brackets 4315?)

3

The pci.id for Broadcom cards sometimes but not always matches the model number; only Broadcom knows why. It is not significant to your problem.

Get the module to load automatically on boot with:

sudo -i
echo b43  >>  /etc/modules
exit

You should be all set.

If you find you have a conflicting blacklist, please do:

gksudo gedit /etc/modprobe.d/blacklist.conf

Remove the line 'blacklist b43' save and close gedit.

6
  • Works like a charm. But is this not a bug in the 13.10 setup procedure for the Broadcom driver? Should the above line not be inserted into /etc/modules automagically (or something somewhere else in the boot procedure)? I see that others have this problem, too. I am willing to file a bug report (I am new to Ubuntu, came from SuSE).
    – ubuplex
    Dec 21 '13 at 16:35
  • There is probably a conflicting blacklist somewhere in your system from where you tried to install another driver and incorrectly removed it. Are there any suspicious files related to bcm in /etc/modprobe.d? Any listings in /etc/modprobe.d/blacklist.conf?
    – chili555
    Dec 21 '13 at 16:43
  • Do you mean this: $ grep -i bcm /etc/modprobe.d/* /etc/modprobe.d/blacklist.conf:blacklist bcm43xx (This carriage return comment behaviour is making me crazy.) Yes, I have tried to install and remove some bcm-related drivers according to the tutorials I have read. It seems to me that something has changed in 13.10 so that some tutorials are not valid any more.
    – ubuplex
    Dec 21 '13 at 17:04
  • "blacklist bcm43xx" wouldn't be effective as there is no module bcm43xx in 13.10. Please grep b43 instead.
    – chili555
    Dec 21 '13 at 18:03
  • As requested: $ grep -i b43 /etc/modprobe.d/* /etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb. /etc/modprobe.d/blacklist.conf:blacklist b43
    – ubuplex
    Dec 21 '13 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.