1

I'm trying to set up the scanner driver for my Epson WF-3520 printer. I started with

sudo dpkg -i iscan-network-nt_1.1.1-1_amd64.deb

after downloading that `.deb' file from the Epson website. Unfortunately, this fails with an error:

Unpacking iscan-network-nt (from iscan-network-nt_1.1.1-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of iscan-network-nt:
 iscan-network-nt depends on iscan (>= 2.29.3); however:
  Package iscan is not installed.

dpkg: error processing iscan-network-nt (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 iscan-network-nt

Based on previous discussions here and here, I need to start by installing `iscan-data_1.22.0-1_all.deb', but I can't find this. Does it exist?

UPDATE: Even after finding and installing iscan-data_1.22.0-1_all.deb, I get exactly the same error as listed above when I run sudo dpkg -i iscan-network-nt_1.1.1-1_amd64.deb. This is turning into a different kind of question ... Follow the progress here!

4
2

old link to Epson page no more exists new link here: http://support.epson.net/linux/en/iscan_c.html

0

Downloaded iscan-data from https://docs.google.com/file/d/0B0OFSi_IZfiHallMbFZOMmlVWG8/edit?pli=1 and installed it through Ubuntu Software Center. Installed both iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb and iscan-plugin-cx4400_2.1.3-1_amd64.deb downloaded from http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX. Give printer no, say, CX5500 and Choose 'Linux' in the OS > click on the magnifying glass (search), Click on 'Download' > Accept and download.

The Printer driver pips-common-3.0 is still giving trouble due to dependencies' issue. Could overcome ./configure step, but stuck in 'make' due to some header file error. Worked around by natively choosing System Settings > Printers > Add etc. Keep the printer connected and switched on.

This is reinstallation and earlier also by similar workaround, my EPSON CX5500 AIO Scanner, printer and Copier was working (better than Windows 7).

Hope this is useful.

0

For all Linux drivers for Epson go here:

http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX

Enter the name of your printer ...

Some drivers have to be installed in the right order, iscan-network was giving an error until I first installed the other drivers first.

1
-2

According to the Epson FAQ you need to install the iscan and iscan_data packages from this Epson web page

2
  • seems like the right idea, but the [second] link provided seems to be in some other language. @douggro in the comments above seems to have the right link.
    – zkurtz
    Dec 20 '13 at 18:08
  • second link is down ATM
    – Elder Geek
    Oct 30 '14 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.