I'm running Ubuntu 12.04 64-bit VPS with 512MB of Ram and a 15GB HDD. On separate, fresh/new VPS servers, I've installed LXDE, Lubuntu and Xubuntu using tightvnc - on separate VPS server. On all occasions I am unable to use Chromium.

Edit: I tried LXDE on Ubuntu 10.04 and everything is working. This seems to be an issue on Ubuntu 12.04.

To clarify, these are remote VPS servers that I VNC into. There is no monitor installed on the remote machine.

I click the icon to launch Chromium, an purple-ish color screen pops up as it tries to launch, and then in a split second later, it crashes. Sometimes I can see the Chromium address bar, tabs, etc for a brief moment as it tries to run.

If I try to run from the command line I get:

Xlib extension “RANDR” missing on display ":1"

On random instances, Chromium will try to send a crash report. In those notes I noticed this...

can't open profile /home/user1/.config/chromium/Default/Preferences

I looked in that folder and indeed there is no Preferences folder. So I create a Preferences folder, try to run Chromium and the folder is renamed Preferences.bad.

I then delete the entire Default folder, tried to launch Chromium and a new Default folder is created. Chromium crashes and still no Preferences folder is created within that new Default folder.

Seems maybe there is a permissions issue or something, but I can't put my finger on it. Here is exactly how I install these desktop environments, step-by-step. Maybe you can see something I'm doing wrong.

I deploy new 64-bit Ubuntu VPS. I SSH into the server as root and run the following commands...

apt-get update
apt-get upgrade
apt-get install lubuntu tightvncserver

I then add a VNC user and set passwords...

adduser user1
su - user1

As root, I edit /etc/init.d/vncserver

export USER="user1"
OPTIONS="-depth ${DEPTH} -geometry ${GEOMETRY} :${DISPLAY}"
. /lib/lsb/init-functions

case "$1" in
log_action_begin_msg "Starting vncserver for user '${USER}' on localhost:${DISPLAY}"
su ${USER} -c "/usr/bin/vncserver ${OPTIONS}"

log_action_begin_msg "Stoping vncserver for user '${USER}' on localhost:${DISPLAY}"
su ${USER} -c "/usr/bin/vncserver -kill :${DISPLAY}"

$0 stop
$0 start
exit 0

edit home /home/user1/.vnc/xstartup and for this example I add (for lubuntu):


#xrdb $HOME/.Xresources
xsetroot -solid grey

#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &

autocutsel -fork
openbox &
/usr/bin/lxsession -s Lubuntu -e LXDE &

Update file permissions to allow users to start X Server

chown -R user1. /home/user1/.vnc && chmod +x /home/user1/.vnc/xstartup
sed -i 's/allowed_users.*/allowed_users=anybody/g' /etc/X11/Xwrapper.config

Make /etc/init.d/vncserver executable and start VNC server:

chmod +x /etc/init.d/vncserver && service vncserver start

Add VNC server to automatically start on reboot:

update-rc.d vncserver defaults

I then start TightVNC Viewer on my Windows machine and enter theserverip::5901 to access the desktop.

I've also tried installing the desktop environment with xrdp and rdp into the desktop as root, and same issue. So I think that eliminates issues with tightvnc.

There seems to be no issues with any other applications on the dekstop. Firefox works just fine, but unfortunately I need to make Chromium work in this case.

Is there something I'm doing wrong with my setup?

  • I noticed on my local PC running xubuntu on VirtualBox that there is no Profiles folder in Chromium either, however Chromium runs fine in this environment. So must be something else going on here. – rivitzs Dec 20 '13 at 16:31
  • Installed lubuntu on virtualbox running my local machine and chromium runs just fine, so something definitely strange going on here. – rivitzs Dec 21 '13 at 0:03
  • Tried with Ubuntu 10.04 and everything is working. Must be something to do with Ubuntu 12.04. – rivitzs Dec 21 '13 at 13:46
  • Braiam, yes I restarted the server with no luck. Edited the original question as you suggested. Thanks! – rivitzs Dec 21 '13 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.