14

So I had a Ubuntu 13.04 installation and I had encrypted my hard drive while I was doing installation. I was playing around and mistakenly deleted all the partitions, now I downloaded lUbuntu 13.10 x86 Desktop but when I am trying to install it says "Unsafe swap space detected"

enter image description here

I am clueless on how to fix this error.

  • At what point of the installation does this error message come up? Did you try completely formatting your hard disk? What comes up if press "OK"? – jobin Dec 20 '13 at 10:24
  • Nothing it just get aborted and then you need to try again. But it fails all the time. However how I can completely format my hard disk using lubuntu? – Django Anonymous Dec 20 '13 at 10:29
  • I am not sure whether lubuntu gives you the option to try it, if not, you may need to use Ubuntu(any version should work) to "Try Ubuntu" and then use gparted to delete all partitions and then try again. – jobin Dec 20 '13 at 10:32
  • I have already deleted all partitions using gparted even when i try to format disk it says "Error Formatting Disk" Error syncronizing after initial wipe. Timed out waiting for object (udisks-error-quark,0) – Django Anonymous Dec 20 '13 at 10:33
24

Try to boot via "Try Ubuntu" instead of "Install Ubuntu" and run the command:

sudo swapoff --all

From the terminal. (ctrl+alt+t)

Then run the Install Ubuntu from the desktop. The error should stop appearing.

See also this related Lubuntu/ubuntu bug report

  • 1
    It works, thanks. Well, this problem is still there in 15.04. I wonder when it is going to be fixed? – Vladislav Rastrusny Apr 25 '15 at 12:30
  • 4
    Still a problem in 16.04! – gojomo Apr 29 '16 at 7:09
  • 5
    Still a problem in 17.04 – user8437812 Apr 27 '17 at 16:59
  • 2
    Still a problem in 18.04 – James Nov 12 '18 at 16:01
9

Len's solution of running sudo swapoff -all is possible without booting via "Try Ubuntu".

When you get the error, use CTRL-ALT-F1 to get to a terminal and run the command there.

Use CTRL-ALT-F7 to return to the graphical environment when you're done.

It worked for me. I did so after going back to the language selection screen, but it may work from the partition manager stage. I would expect the check is only being done at the moment one attempts to change a partition.

  • It should be kept in mind that this requires enough RAM in the first place ;) – 0xC0000022L Jul 27 '14 at 22:03
  • 1
    How do I get back into the setup menu after doing this? – Kajetan Abt Oct 30 '14 at 20:29
  • Same question as @KajetanAbt, quite annoying. – Laurent W. Apr 9 '15 at 19:59
  • If you want login and password then try lubuntu for username and just press enter for password. – Omar Tariq Jan 12 '16 at 14:55
  • When installing Lubuntu 16.04.1, I encountered this issue. For some reason, there was no virtual consoles available so I had to restart and select Try instead of Install in order to access a terminal device. – Anthony Geoghegan Oct 10 '16 at 9:30
1

I had the same problem, there's definitely something wrong with the installer (I was trying to set up 14.04 with encrypted partitions on different drives, with / on my small SSD and /home /usr /tmp /var and swap on my HDD). But I played around with it, restarted the installer/rebooted a number of times, and here's how you work around it:

Set up all your actual partitions, including your encrypted containers. I believe it necessary to include an encrypted partition for swap, so make sure to make one of suitable size for it.

Once you have them all set up, THEN, and only then pin them to actual mount points. I started with swap and then moved on to /home and so on.

-1

It is this Bug That still exists in Lubuntu 14.04.2 Desktop i386 version. That's what i've tested - maybe this safe's some other people's nerves.

I got it working using the alternate-cd (14.04.1 i386) but there you need to make sure to select the "Install" method - not the "expert install" and not "install lubuntu" and when grub asks you to install to MBR say "No" because that is another bug and you will then be given the option to specify the correct device to install grub to.

Made a detailed answer specified for 14.04 now: Link

Greets

An

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.