16

I just set up my machine and plugged in my headset, but now I'm currently wondering how to disable the audio loopback from my microphone.

I've found nearly the same question over here

How do I turn off audio echo from microphone to local speakers?

But my Interface looks different, and there are a hell lot of entries if run

pacmd list

So I'm not sure wich one to pick.

16

The link in your question disables the mic, and in my case it even didn't help, the mic became disabled for applications, but the echoing stayed. What I've done to solve this:

  1. Open alsamixer in terminal.

  2. Press F3 to make sure you are on the playback tab.

  3. Find any interesting setting there for "Mic" or "Capture" which shouldn't be there, since we are on the playback tab.

  4. Either mute that volume meter by pressing M or lower its level to zero with the cursor keys.

    Now it shouldn't echo back, and recording with the mic should be also possible.

  5. If it still echos back, then you have to mute the mic volumes, just go back to alsamixer press F4 and mute what you have to on the capture tab.

2
  • 6
    For me it was alsamixer -> press F6 -> select correct soundcard, e.g. intel PCA -> for me there are like 10 volume meters showing and more are to the right, like 20 in total. One is called Loopback which instead of a volume meter only shows Enabled. Select that one with left / right arrow and then switch to Disabled by pressing down arrow. The change should apply immediately. – mxmlnkn Dec 19 '16 at 20:43
  • Wow, was trying to figure this duplex echo of my recording in QTractor for hours... Now in alsamixer F4 - I decreased "Capture 1" to zero, and increased "Capture" instead. No more echo :-) Thank you! – Noam Manos Mar 27 '20 at 14:06
3

For anyone facing this, I had same issue in Ubuntu 18.04, and was resolved by changing Settings -> Sound -> Output -> Profile (drop down selection) and used 'High Fidelity Playback' instead of 'Headset Head Unit'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.